Carbon.h not found

Dec 11, 2013 at 11:31am

Carbon.h not found

I’m trying to build an example project but I keep getting this error:

/MaxSDK-6.1.4/c74support/max-includes/macho-prefix.pch:5:10: ‘Carbon/Carbon.h’ file not found

macho-prefix.pch is there, and it contains:
#include
#include

I can’t find Carbon.h and QuickTime.h files. I’m using Xcode 4.6.3.

#275449
Dec 11, 2013 at 11:33am

It erased the code. Here it is:
#include <Carbon/Carbon.h>
#include <QuickTime/QuickTime.h>

#275450
Dec 11, 2013 at 10:28pm

Have you tried just to comment those lines (sorry i cannot help much i’m still with an older system/SDK)?

#275477
Dec 12, 2013 at 12:50am

I have found that it’s related to OSX 10.9.

If I go to the “Build Settings” and change the BASE SDK to OSX 10.8 or 10.7 it doesn’t give that error, but it gets stuck on the “Creating Universal Library” step of the building process.

This is happening with OSX 10.9, Xcode 4.6.3 and SDK 6.14.

#275482
Dec 12, 2013 at 1:12am

Ok, the 6.14 SDK works now with XCode 5 instead of Xcode 4.

Where is this info? This is so frustrating…

#275484
Dec 12, 2013 at 9:06am

The Carbon and QuickTime libraries have been deprecated for years and years, and Apple dropped all support for them in like, Snow Leopard or something like that. There’s a QuickTime X that’s supported, but Steve Jobs killed Carbon at the change over to Intel processors.

I’m sure this has been discussed on the dev Forum before, have you looked? (It’s possible that the other discussions aren’t exactly your question, but all stuff worth knowing).

The problem seems to be that every time Apple changes XCode, Cycling basically has to modify all their header files to match. But when Cycling changes the headers to work with XCode version x.y, they no longer work with version x.(y-1) or x.(y+1); never mind (x-1).z.

#275525
Dec 12, 2013 at 9:36am

I know this is a pain between the Xcode version, the OSX version and the SDK version. I already know that with OSX 10.8 and SDK 6.0.4 I need Xcode 4.6.1 or it won’t work, but SDK 6.0.4 and Xcode 4.6.1 don’t work if you have OSX 10.9, because in that case you need SDK 6.1.4 and Xcode 5.

I know there’s nothing to blame to cycling74 regarding OSX and Xcode changes, but I would love to know where all this info is, if there is actually somewhere, so I don’t have to crosstest everything each time something changes until I find which version works with which.

And yes, I obviously searched the forum and I hope this own post serves people struggling to get this working.

#275529
Dec 12, 2013 at 10:17am

Sadly i don’t think there is a better place than here for such infos.

#275536

You must be logged in to reply to this topic.