Forums > MaxMSP

cartopol crashes 4.6.2

January 15, 2007 | 6:38 pm

I tried to open an old patch in 4.6.2, but it consistently crashed Max. After some investigation, I narrowed the problem down to the cartopol object. When I try to create a new cartopol object in 4.6.2, Max is sometimes kind enough to return an error message before crashing. It says I am trying to open an object that has the same name as a patcher, then it lists cartopol.pat, showing it in both my Max46 directory and in Max46/max-help/. A system search for "cartopol" only shows the expected results: cartopol.mxo, cartopol~.mxo, cartopol.help, and cartopol~.help in their proper places (and also in the Max45 installation). The problem is not replicated with cartopol~ or poltocar, or any other object that I can find. Also, 4.5.7 on the same system does not have the problem. Does anyone have any clues what may be happening here?

Max/MSP 4.6.2
Jitter 1.6.2
PowerBook G4 1.67
MacOS 10.4.8

Thanks,
Tim


January 15, 2007 | 6:42 pm

For accuracy sake, the directories that max reports finding cartopol.pat in are /Applications/MaxMSP 4.6/ and /Applications/MaxMSP 4.6/max-help/.

Thanks again.


January 15, 2007 | 7:17 pm


January 15, 2007 | 7:40 pm

Read your sentence again:
"It says I am trying to open an object that has the same name as a
patcher"

I’m sure you’ll find a patcher which have the same name as an object?
or this inverse;-)

I couldn’t remember the exact wording of the error, and couldn’t replicate it (just the crash!) One way or the other. The problem is that there *is no patcher that has the same name as the object.* I’ve even looked for hidden files. Nothing on the system called cartopol.pat. That’s the problem–Max window says there is, but I don’t find it anywhere.

Tim


January 15, 2007 | 8:15 pm


January 15, 2007 | 9:29 pm

I tried deleting prefs and restarting. I checked to ensure that the search path was not including any old directories. Still the crash (before any error can be printed to the Max window). Here is the crash report…


January 15, 2007 | 9:45 pm

I’m not positive how max currently search for objects, but in the past if you had a standalone app made in max, and that app was in the search path, max would have a way of finding the objects/abstractions contained in the standalone. Again, I’m not sure if this is an issue anymore, but may be worth a shot. So…any standalones in that search path? try reverting back to the default max search paths (delete your prefs). Max wouldn’t lie…if it is telling you it is finding an abstraction of the same name…it’s finding an abstractionof the same name.

David


January 15, 2007 | 10:32 pm

Okay, I took my other two Max-related directories out of the search path (some of which contained some standalones that I have downloaded, etc.), and that seemed to solve the problem. I don’t understand why the Max window reported /Applications/MaxMSP 4.6/cartopol.pat and /Applications/MaxMSP 4.6/help-files/cartopol.pat, when those files are not listed by the system, and when the offending file is evidently elsewhere (either Desktop or in a subdirectory of Documents).

Anyway, I think it works now. Thanks for the help!

Tim


January 15, 2007 | 10:36 pm


January 15, 2007 | 11:03 pm

After taking the Desktop directory out of Max’s search path, a new object called cartopol.mxo or even cartopol no longer crashes Max. The strange thing is after I reset the File Preferences to exactly what they were before, it still no longer crashes.

Thanks again for your help!

Tim


Viewing 10 posts - 1 through 10 (of 10 total)