Forums > MaxMSP

changing momentary buttons on a Nanokontrol to latch

June 21, 2009 | 9:03 am

Does anyone know how to convert a temporary midi bang to a ‘latch’?

I’ve got a Nanokontrol, and all the buttons are temp rather than latches. So when I’m trying to assign one to a toggle, it is only ‘active’ of course, while the button on the nano is depressed..

(i.e. it’s sending out 127 when it’s pressed, and 0 when it’s not..)

I just need something that will make it ignore the 0, and not unclick the max button until the next 127 message is sent.. I tried ‘select’, but as soon as it stops sending the 127 message, the box unselects..

Anyone got any ideas?

Kris


June 21, 2009 | 9:05 am

I had a similar issue trying to use a sustain pedal as an on/off switch.

Check out change, togedge and trigger


June 21, 2009 | 9:06 am

Correction..

With the ‘select 127′ object in there, the box is checked, and only UNCHECKS when the button is pressed on the Kontrol.. If that makes sense.


June 21, 2009 | 9:19 am

freakin brilliant.. fixed it Very Happy

legend!


June 21, 2009 | 9:27 am

So the [sel 127] method in the patch below doesn’t work for you?

lh

– Pasted Max Patch, click to expand. –

June 21, 2009 | 9:29 am

I was going to suggest this, in case your interested:

– Pasted Max Patch, click to expand. –

June 21, 2009 | 12:11 pm

i ended up doing this with togedge..

– Pasted Max Patch, click to expand. –

it was weird, the select object wasn’t making it latch, but thereishopeforus, in your patched it WAS.. Hmmmm…!


June 21, 2009 | 12:14 pm

actually.. another question with this patch..

When I send in two commands at once, i.e. pushing up two faders at once, only one works.. Is thre an easy way to enable multiple data streams? check out the patch below..

– Pasted Max Patch, click to expand. –

June 21, 2009 | 12:47 pm

try this with midi in replacing ctl in:

– Pasted Max Patch, click to expand. –

June 21, 2009 | 12:55 pm

GENIUS.

Thank you SO MUCH. Man. Every time I use Max/learn something new via this awesome forum I love it more and more. Most fun program EVER.


June 21, 2009 | 3:42 pm

You can change the button behavior from "momentary" to "toggle" (I mean in the Editor of nanoKontrol), and then use only a toggle in max.
But if you need change the scene, maybe it’s better the solution above, because nanoKontrol doesn’t recall the state of the toggle if you change scene.


June 21, 2009 | 3:45 pm

yeah i did think of that.. but the problem was that i use the controller in other apps as well, and wanted to avoid having to go and change all the mapping i’d already set up. For the moment anyway.. It’s working awesomely now though.


Viewing 12 posts - 1 through 12 (of 12 total)