Chapter 12 Tutorial Question!

Jun 11, 2006 at 6:25pm

Chapter 12 Tutorial Question!

Hey,

I am new to MAX/MSP, and I am on chapter 12 in the tutorial that comes with the demo download.

The patch on the left and right are reading the input signals from the Yamaha S90 keyboard I have plugged into my interface via MIDI, but the patches near the bottom right which are supposed to be playing my Yamaha synthesizer are not communicating with it. They will run the DLS synth on my Mac, but will not play the Yamaha and I assume they should be.

If it matters, I have the Yamaha sending on Port 1, recieving in Omni mode. I’m connected exactly how the tutorial says I should be. If you know why the patch is not playing my synthesizer, please let me know.

Thank you thank you thank you.

– Kyle M. Terrizzi –

#26370
Jun 11, 2006 at 6:53pm

Double click on the midi/noteout object. A pull down menu will appear. The
rest should be cake.

-lcc

#78742
Jun 11, 2006 at 6:58pm

HAHAHAHAHAH! THANK YOU SOOOOOOOOOOOOOOOOOO MUCH! WOOHOO! THE BEST PART OF MY DAY SO FAR!!!!!!!

I am so excited. A great work begins.

#78743
Jun 11, 2006 at 10:54pm

At some point now you might find it worthwhile to read the two chapters
on “Using MIDI” and “Ports: How MIDI Ports Are Specified” from the
MaxGettingStarted.pdf. They will provide you with additional information
on how to set up MIDI in Max so that you can set what MIDI device to use
as an argument to the various MIDI objects. That way you won’t have to
double click and select every object for MIDI input and output each time
you open your patch.

Best,
Trond

#78744
Jun 11, 2006 at 11:57pm

yeah, i have read those portions. i went through the getting started manual before i began the tutorials, but still i had no luck. i tried setting the i/o abbreviations for the interface as specified by the object arguments, and it didn’t work, but the double-click method did.

hmmm…

#78745
Jun 12, 2006 at 12:37am

Check the helpfile for [midiin]
Its made life much easier for me and my band-mates.

We all have the same code but it auto-loads our different midi interfaces so
that we don’t need to double click on the things when we go up on stage…

#78746
Jun 12, 2006 at 1:27am

thanks for the heads up. i’ll give it a look.

#78747
Jun 12, 2006 at 6:48am

If you are able to post a screenshot somewhere of the MIDi setup in
AudioMIDISetup (assuming that you are on Mac) and the Max MIDISetup
Window this should be possible to sort out.

Best,
Trond

#78748
Jun 12, 2006 at 3:56pm

thanks for the responses, but actually, i have it all figured out now. it wasn’t working before, but now for some reason when the desired output abbreviation is used, everything works fine. good for me. so thanks everyone.

#78749

You must be logged in to reply to this topic.