Clicks and crazy behavious using upsampling and parallel in Poly~

Feb 18, 2014 at 12:05pm

Clicks and crazy behavious using upsampling and parallel in Poly~

Hi,
I get clicks and crazy behaviours using upsampling 2 and @parallel 1 in Poly~

This behaviour seems to happen only when i use @parallel 1 as argument, not while switching with the attrui object…

see patch attached.

Thanks,
Alexandre

P.s: And in a more complex patch it seems i also have crazy cpu problems without upsampling, and even also without using parallel, while sending a lot of max messages inside the poly~ while without using poly~ my abstraction works super fine. I’m kind of generally having bad luck with poly~ and my complex patches…

#281491
Feb 18, 2014 at 12:10pm

I precise that this is not happening with max 5 but only max 6. I’m on max 6.1.6, os 10.8.5, MBPro i7 2011.

#281493
Feb 18, 2014 at 12:24pm

(and i believe that there is no parallel processing happening while switching with the attrui object or with the toggle in the inspector)

EDIT: oh yes this is because we have to turn off and on DSP again… So now we have the same clicks/weird noise using attrui/inspector.

#281495
Feb 18, 2014 at 12:37pm

Sorry to hear your having trouble. Can’t test the patch at the moment to say if it does the same on my machine but I do believe that if you turn parallel on/off you have to restart DSP for it to take effect.

#281496
Feb 18, 2014 at 2:38pm

I lost 2 DAYS of work of 2 people (me and a developper i pay) because of this strange behaviour. (Trying to figure out what was wrong in our complex patch before we finally put @parallel 0) It’s not just a restarting-DSP thing.

#281511
Feb 19, 2014 at 2:39am

I’m not getting clicks but the @parallel 1 version definitely has a buzz that’s not the sine going into it.

OSX10.8.5
Max616

#281543
Feb 19, 2014 at 10:35am

It appears to me that the issue is with the resampling filters. The distortions are not there for me if I turn it off.

#281581
Feb 27, 2014 at 10:44am

yep, that’s the resampling filters that seem to mess-up with parallel…

#282364

You must be logged in to reply to this topic.