Forums > MaxMSP

Clock problem with max on PC

March 9, 2011 | 10:38 am

Hi everyone,

I have a little (well, a big in fact) problem when using max on my PC. This is the first time I use it, and there is a problem with the clock. When I am using the metro, I cannot obtain a constant beat…in fact this is absolutely chaotic…
I tried to use the X-groover (a beat box), and there is the same problem, it is impossible to have a constant beat.
So I suppose there is a clock problem somewhere, but I do not know where, and why. Is there anybody who had the same problem, or who know how to fix it?

Thanks


March 9, 2011 | 10:56 am

do you have overdrive turned on?


March 9, 2011 | 11:10 am

Yes, but if I turn it off, there is still the same problem.


March 9, 2011 | 11:24 am

wait, do you mean you have the timing issue when overdrive is on? it is expected that your timing will be bad when overdrive is off.
If the timing is bad when you have overdrive on, see if scheduler in audio interrupt is on and try to turn that off..

also check it with this patch:

– Pasted Max Patch, click to expand. –

March 9, 2011 | 1:12 pm

I am sorry but I am really a beginner in Max, so I do not really understand what you told me.

What is the "scheduler in audio interrupt" (where can I find this interrup)?
And I do not konw how I can use a code in max (is there a compiler or something?), so I do not know how to try your patch.

Could you tell me?
Thanks!


March 9, 2011 | 1:23 pm

- to find the "scheduler in audio interrupt" setting
go to options – dsp status
alternatively send a message with ‘open’ to a (ez)dac~ or (ez)adc~

- to try the patch:
select and copy the text (including start and end)
choose new from clipboard in max

(if you past your own patch on the forum you should use ‘copy compressed’ and then your patch will look like this)


March 9, 2011 | 2:00 pm

Ok I did it, and it seems that, even with scheduler in audio interrupt off, it is still not very good (but better than with this interrupt on): I have got great variation in the graphics made by your patch…

Do you have another idea where the problem could come from?


March 9, 2011 | 2:51 pm

hmm, then I don’t know… sorry…


March 9, 2011 | 3:29 pm

Well…it seems that the problem was from the computer…because I just used another one and, for that, it works…It will stay a mystery…


Viewing 9 posts - 1 through 9 (of 9 total)