Forums > MaxMSP

CNMAT oscillators~ – no sound

August 10, 2007 | 6:34 pm

Hi,

I’ve been experimenting with the CNMAT externals but seem to be having a problem with the oscillators~ object – I don’t get any sound out of it, either with wavetable~ or by directly sending it messages. This is the only object that doesn’t work for me (BTW I’m on Windoze). Any thoughts?

Cheers,
Chris



jml
August 10, 2007 | 10:58 pm

do you have an example patch to demonstrate the problem?
have you checked the help file?

jl


August 10, 2007 | 11:00 pm

Quote: SecretTheatre wrote on Fri, 10 August 2007 11:34
—————————————————-
> Hi,
>
> I’ve been experimenting with the CNMAT externals but seem to be having a problem with the oscillators~ object – I don’t get any sound out of it, either with wavetable~ or by directly sending it messages. This is the only object that doesn’t work for me (BTW I’m on Windoze). Any thoughts?
>
> Cheers,
> Chris
—————————————————-

I’m getting sound from the help patch as soon as I start audio. Version 1.3 of the object and version 1.1 of the help patch. I’m running WinXP SP2 and Max 4.6.3.

Do you have the latest version? Any errors in the Max window?

mz


August 11, 2007 | 12:51 am

Yes I’m running the same versions, in Max 4.5.5. No errors in the Max window, in fact it says the wavetable is ready to synthesize. But starting audio gives me nothing. Odd, as everything else works fine.


August 11, 2007 | 5:53 pm

I get the same problem on another WinXP machine (same versions of Max and the CNMAT externals).



jml
August 11, 2007 | 7:49 pm

I would suggest upgrading your vers. of Max to 4.6.3 on XP, and then trying things out again…
There may be an earlier vers. that might work better w/ 4.5.5… not sure.

jl



jml
August 11, 2007 | 7:54 pm

although secretTheatre hasn’t mentioned what it’s preferred vers. of the obj is yet, it looks like v1.3 is not available the downloads site; just v1.2 for winxp;
should still be fine w/ 4.6.3, afair.

jl


August 13, 2007 | 5:54 pm

Quote: jml wrote on Sat, 11 August 2007 12:54
—————————————————-
> although secretTheatre hasn’t mentioned what it’s preferred vers. of the obj is yet, it looks like v1.3 is not available the downloads site; just v1.2 for winxp;
> should still be fine w/ 4.6.3, afair.
>
> jl
>
—————————————————-

Sorry, competing versioning systems.

1.2 is the correct number for the current version, which is the version I tested on Windows XP and Max 4.6.3.

Can you upgrade to 4.6.3 and test? Are all your problems on 4.5?

Another problem could be with wavemaker.js. Double-click on the buffer~ "sinetable" on the right. Do you see a sine wave in there?

mz


August 13, 2007 | 8:10 pm

Hi mzed,

Yes, wavemaker.js is working for me, there’s a sine in the buffer~. I’m going to upgrade to the latest Max soon, so will test the oscillators~ object then.


Viewing 9 posts - 1 through 9 (of 9 total)