Forums > Java

code working on intel-macs but not on ppc-macs

June 13, 2007 | 8:46 pm

hi guys,
first of all, excuse my bad english. it’s not my native language.

Well,
im a college student, working with some friends on a project to move sound around in space.
the software has to work on both, ppc-macs and intel-macs running on mac osx 10.4.9 and max/msp 4.6.3.
Currently running on the jvm 1.5.07.

Like the title explains, our code is working properly on intel-macs but creates the "Beachball of Death" if our application is running on an ppc-mac. Absolutely no error-message appears if our error_logging is ON. But if its OFF the patch appears but the console says: could not instantiate s2m_main_GridEditor (the main class of the application) and nothing happens

We then thought of some memory-issues and configured the java_config of max/msp to load it once with 128, once with 256, and once with 512 mb use of memory. but everytime the same problem.

BUT: if we start our application inside eclipse (ppc-mac) it’s running great, as it does on intel-macs inside max/msp

you guys are our last chance to get it running. any suggestions?
thanks in advance


June 13, 2007 | 11:07 pm

Are you sending lots of messages really fast ?

Does it have a UI ?

t

On Jun 13, 2007, at 13:46 PM, harry wrote:

>
> hi guys,
> first of all, excuse my bad english. it’s not my native language.
>
> Well,
> im a college student, working with some friends on a project to
> move sound around in space.
> the software has to work on both, ppc-macs and intel-macs running
> on mac osx 10.4.9 and max/msp 4.6.3.
> Currently running on the jvm 1.5.07.
>
> Like the title explains, our code is working properly on intel-macs
> but creates the "Beachball of Death" if our application is running
> on an ppc-mac. Absolutely no error-message appears if our
> error_logging is ON. But if its OFF the patch appears but the
> console says: could not instantiate s2m_main_GridEditor (the main
> class of the application) and nothing happens
>
> We then thought of some memory-issues and configured the
> java_config of max/msp to load it once with 128, once with 256, and
> once with 512 mb use of memory. but everytime the same problem.
>
> BUT: if we start our application inside eclipse (ppc-mac) it’s
> running great, as it does on intel-macs inside max/msp
>
> you guys are our last chance to get it running. any suggestions?
> thanks in advance


June 13, 2007 | 11:09 pm

also a while ago i sent a message to the list about getting a java
debugger running with the
JVM inside max. That could maybe help narrow it down if all else fails!

t

On Jun 13, 2007, at 13:46 PM, harry wrote:

>
> hi guys,
> first of all, excuse my bad english. it’s not my native language.
>
> Well,
> im a college student, working with some friends on a project to
> move sound around in space.
> the software has to work on both, ppc-macs and intel-macs running
> on mac osx 10.4.9 and max/msp 4.6.3.
> Currently running on the jvm 1.5.07.
>
> Like the title explains, our code is working properly on intel-macs
> but creates the "Beachball of Death" if our application is running
> on an ppc-mac. Absolutely no error-message appears if our
> error_logging is ON. But if its OFF the patch appears but the
> console says: could not instantiate s2m_main_GridEditor (the main
> class of the application) and nothing happens
>
> We then thought of some memory-issues and configured the
> java_config of max/msp to load it once with 128, once with 256, and
> once with 512 mb use of memory. but everytime the same problem.
>
> BUT: if we start our application inside eclipse (ppc-mac) it’s
> running great, as it does on intel-macs inside max/msp
>
> you guys are our last chance to get it running. any suggestions?
> thanks in advance


June 13, 2007 | 11:16 pm

hi,
yes it has a ui.
right now, we are not sending any messages (if you mean messages over network), but we will in future, using the osc protocoll.


June 14, 2007 | 1:22 am

How is the UI being started?

Did you try doing it using SwingUtilities.invokeLater to make sure it
is displayed by the AWT Thread?

t

On Jun 13, 2007, at 16:16 PM, harry wrote:

>
> hi,
> yes it has a ui.
> right now, we are not sending any messages (if you mean messages
> over network), but we will in future, using the osc protocoll.


June 17, 2007 | 7:32 pm

yiehhaaaa :D
thanks man,
youre the greatest.

we tried to do what you’ve said
and finally it’s running :)
just a little bit slow,
but hey it’s finally running

BIG THANKS

btw: we added to our mainclass

public S2M_GridEditor()
{
final S2M_GridEditor a = this;
SwingUtilities.invokeLater(new Runnable() {
public void run() {
//logging();s2mGUI = new S2M_GUI_Main(S2M_GlobalDefines.START_GRIDEDITOR);
s2mGUI.setMainObject(a);
s2mGUI.setVisible(true);
}
});
}


Viewing 6 posts - 1 through 6 (of 6 total)