Forums > MaxMSP

combine sliders in a multislider

July 25, 2010 | 9:45 am

Hey I’d like to combine different sliders within a multislider to get the same values.
So for example I’d like to combine slider 1 and 2 to have them the same value (see patcher).
But I get a slight difference in the values of the two sliders (see numberboxes)

Anyone knows why and how I maybe could prevent it?
Thanx so much
Peer

– Pasted Max Patch, click to expand. –

July 25, 2010 | 1:01 pm

found the solution…just have to choose integers as output values and rescale them (for example from 0 till 1000) in the inspector and if I want my floating point numbers back I’ll do a vexpr calculation afterwards…kind of complicated to get the result I want, but hey, that’s how it is ;-)

Pitty though that there isn’t an option for the multislider to combine different sliders……

Have a great sunday.
Cheers
Peer


July 25, 2010 | 1:40 pm

can’t solve the problem…have a look at the patcher please

– Pasted Max Patch, click to expand. –


Ch
July 25, 2010 | 3:45 pm

Hi,
in your messages, replace "set" by "select".


July 25, 2010 | 3:56 pm

shit…you are right ! what is the difference? Why do I have a slight de-calibration with ‘set’ but not with ‘select’.

Don’t understand the reason for that.

Thanx man :-)
Cheers
Peer



lul
July 25, 2010 | 3:58 pm

Hello,

it seems that your config generates timing issues, slider 1 value arriving always sooner than the others it tries to send it’s values…

btw, I searched another way of doing what you want, and this kind of patching seems easier,… but I may not understand exactly what’s your purpose.

Anyway…

– Pasted Max Patch, click to expand. –

July 25, 2010 | 4:06 pm

Hey lul,

very friendly. Well I use it in a very complex situation (with buffer positions) – bit difficult to explain and the patcher which I posted is just a very basic form of what I’m using.
Thanx for your efforts. Can’t really use what u did cause I need to control the sliders themselves…

Anyway what ‘CH’ posted works perfectly. So I’m fine. Just don’t understand why I got the different values with ‘set’ but not with ‘select’ ;-)

Ciao
Peer


July 25, 2010 | 7:40 pm

"Just don’t understand why I got the different values with ‘set’ but not with ‘select’ ;-)"

Probably it’s "what you see isn’t what you get"… the visual appearance of the sliders won’t match the numbers coming out into the [unpack], because "set" won’t cause the list to output, while "select" will.

This might not be exactly what you’re after, but it might give some other ideas on how to link various sliders to one master slider. Hurray for transparency!

– Pasted Max Patch, click to expand. –

July 26, 2010 | 9:23 am

Hey thanx to you all,

finished my patcher. Have a look if you want ;-)
Guess it’s much too complicated for the result I get, but couldn’t figure out a better way.

Cheers
Peer

Attachments:
  1. 25.6_maxpat.zip

Viewing 9 posts - 1 through 9 (of 9 total)