Forums > MaxMSP

Compile Shell External as UB

September 1, 2006 | 5:41 am

Hello from Italy,

I urgently need to compile as Universal the Bill Orcutt’s shell object. Bill
kindly provided me the source code (carbon) since he doesn’t have a computer
right now to do the job.
I tried using Xcode, but I got a couple of errors from the source code that
I’m not able to correct (unfortunately for me I don’t have enough
competence).
Can anybody give me a hand? I can mail the code (it’s just few lines) or it
can be downloaded at: http://publicbeta.cx/max/ (shell.zip).

Alternatively if anyone has or knows about a .mxo that is a unix shell (no
java or javascript but real universal) I will buy it since I do really need
to cross a big max patch (www.soundbuilder.net) I did last year and the
"shell" is the only 3rd party object I used…

I may give away a SoundBuilder as exchange.

Thanks very very much.

Ciao ciao
Riccardo Mazza


September 1, 2006 | 5:54 am

Hi Riccardo,
I believe Jeremy Bernstein has arleady taken a stab at this. I
remember there were some issues, but it might just work for you:

http://www.cycling74.com/twiki/bin/view/Share/JeremyBernstein?t=2006-08-15T23:23Z?rev=1.5

best,
wes

On 8/31/06, Riccardo Mazza wrote:
> Hello from Italy,
>
> I urgently need to compile as Universal the Bill Orcutt’s shell object. Bill
> kindly provided me the source code (carbon) since he doesn’t have a computer
> right now to do the job.
> I tried using Xcode, but I got a couple of errors from the source code that
> I’m not able to correct (unfortunately for me I don’t have enough
> competence).
> Can anybody give me a hand? I can mail the code (it’s just few lines) or it
> can be downloaded at: http://publicbeta.cx/max/ (shell.zip).
>
> Alternatively if anyone has or knows about a .mxo that is a unix shell (no
> java or javascript but real universal) I will buy it since I do really need
> to cross a big max patch (www.soundbuilder.net) I did last year and the
> "shell" is the only 3rd party object I used…
>
> I may give away a SoundBuilder as exchange.
>
> Thanks very very much.
>
> Ciao ciao
> Riccardo Mazza
>
>
>


September 1, 2006 | 8:23 am

The issues appear to manifest on _some_ Intel macs, whereby the
output gets directed to the Console, instead of to the Max object’s
left outlet. Otherwise, the object works. Depending on what you need
it for, this issue may be a dealbreaker. But it’s just waiting for
you to try it out. I’ll check out that copy of soundbuilder, though,
if it’s still on the table. ;)

jb

Am 01.09.2006 um 07:54 schrieb Wesley Smith:

> Hi Riccardo,
> I believe Jeremy Bernstein has arleady taken a stab at this. I
> remember there were some issues, but it might just work for you:
> http://www.cycling74.com/twiki/bin/view/Share/JeremyBernstein?
> t=2006-08-15T23:23Z?rev=1.5
>
> best,


September 1, 2006 | 9:30 am

after a long time i just had it again – a problem that happens rarely but (see subject) which i think started to happen with the first OSX version. once in a while when bringing max back to the front all open windows dissapear. i can still select them from the windows menu and e.g. close/save/edit/select all/copy/paste… but they stay invisible and max doesnt crash.

my experience is it only happens with many open apps and max also being open long (hours/days) and lots of app switching and apps hiding and going into/back from sleep mode . i had this more often with older versions (of max and osx) but it just happend right now with 4.5.7. on 10.3.9. on alubook 1.25ghz, 1gb ram. it also happened on my tibook back then. as i dont had this ever with any other app i suspect rather max than osx to be the problem but thats just speculation… oh and i should mention that for the first time for a long time i have a 2nd monitor connected while patching (so maybe thats why it didnt happen for long?)

and i actually can´t imagine i am the only one to whom this happens/happened

i know my description is vage but it tried to be as specific as possible…

p


September 1, 2006 | 4:16 pm


September 1, 2006 | 4:45 pm

the console! that’s where the messages are! how … useless

do you have any idea why this is happening?

On 9/1/06, Jeremy Bernstein wrote:
> The issues appear to manifest on _some_ Intel macs, whereby the
> output gets directed to the Console, instead of to the Max object’s
> left outlet.


September 1, 2006 | 5:16 pm

Preliminary inquiries seem to indicate that it’s an Apple bug, but
we’re waiting to get more information. If I learn of a workaround in
the meantime, I’ll let you know.

jb

Am 01.09.2006 um 18:45 schrieb Scott Fitzgerald:

> do you have any idea why this is happening?


September 1, 2006 | 7:57 pm


September 2, 2006 | 8:10 am

pure@test.at wrote:
> i am totally sure it has to do with what i described but unfortunately
> its not reproduceable. i just find it striking that it didnt happen for
> ages and its ages since i worked with a 2nd monitor…
>
> no one else ever had this?

Very simple, they did not disapeare, but are hidden by other windows of
other applications.

I guess you still believe, that if an application is in the foreground,
all windows will jump to the front. This is the case if you switch
applications with the dock or the cmd-TAB key, but if you just click on
a single window, only that window will come to the front…

This has changed since OS 9 and its very convenient, especially if you
have millions of Finder windows open and want to drag from a single
Finder window into Max…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


September 2, 2006 | 12:15 pm

Stefan Tiedje wrote:
> pure@test.at wrote:
>
>> i am totally sure it has to do with what i described but unfortunately
>> its not reproduceable. i just find it striking that it didnt happen
>> for ages and its ages since i worked with a 2nd monitor…
>>
>> no one else ever had this?
>
>
> Very simple, they did not disapeare, but are hidden by other windows of
> other applications.

then this could not happen: "i still have the menubar of max and can also select the patcher windows via the window menu – at least then they would have to reappear."

>
> I guess you still believe, that if an application is in the foreground,
> all windows will jump to the front. This is the case if you switch
> applications with the dock or the cmd-TAB key, but if you just click on
> a single window, only that window will come to the front…

i dont believe the first, regulary use the 2nd and am aware of the 3rd
>
> This has changed since OS 9 and its very convenient, especially if you
> have millions of Finder windows open and want to drag from a single
> Finder window into Max…

i do know all this. i love shortcuts, use column view in the finder and in spite of being a mac user i even prefer to navigate with the arrow keys than mouse clickdragging ;) thats all these kinda things i almost daily explain to the not so few friends who call me with their everyday computer probs.

i can asure you its not such a trivial confusion.

sigh… so no one else backing up my experience…

p


September 4, 2006 | 5:47 am

pure@test.at wrote:
> then this could not happen: "i still have the menubar of max and can
> also select the patcher windows via the window menu – at least then they
> would have to reappear."

Ah, I understood the did reapear when selecting them.
If they don’t I don’t know. Do you have a second monitor atached?, did
you try to recenter them with alt-select from the windows menu?

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


September 4, 2006 | 1:15 pm

Stefan Tiedje wrote:
> pure@test.at wrote:
>
>> then this could not happen: "i still have the menubar of max and can
>> also select the patcher windows via the window menu – at least then
>> they would have to reappear."
>
>
> Ah, I understood the did reapear when selecting them.

no they didnt

> If they don’t I don’t know.

thats where i am :)

Do you have a second monitor atached?, did
> you try to recenter them with alt-select from the windows menu?

yeah i had a 2nd monitor attached for the first time for long thats why i suspect this …erm… bug to be related to that. have to admit i didnt know the alt-select trick but i can asure you i didnt overlook the windows in a corner of my screens…

anyway thanks for your hints

p


September 19, 2006 | 1:55 pm


Viewing 13 posts - 1 through 13 (of 13 total)