Compiling problems on XP, missing DLLs on Win 7

Apr 6, 2012 at 5:00am

Compiling problems on XP, missing DLLs on Win 7

Hi,

When compiling my app on Windows 7, and then attempting to run the .exe, I get the following:
JUCEWindow: appname – Sytem Error
The program can’t start because MaxLua.dll is missing from your computer. Try reinstalling the program to fix this problem.

[OK]
Then get:
EventWindow: appname – System Error
The program can’t start because MaxJSRef.dll is missing from your computer. Try reinstalling the program to fix this problem.

[OK]

When compiling on my Windows XP machine, these DLLs are provided, however during the compilation process on XP, I get error messages:

Windows – No Disk
Exception Processing Message c0000013 Parameters 75b6bf7c 4 75b6b7c 75b6bf7c
[cancel][Try Again][Continue]

If I select Continue it the compilation appears to complete successfully.

I’m not sure how to safely proceed with distributing my app given the different problems on each platform.

Seems like it might work to take the Win 7 compilation taht did not have errors and manually copy over the missing .dlls from the XP machine and then hope the result work/runs okay on both?

A bit skittish to do this without better understanding the problem and implications.

Thank you for any guidance.

Peace

#62804
Apr 6, 2012 at 7:16pm

that no disk message may have something to do with an fpic given an absolute path to the picture, i had this problem once and solved by putting the picture to the search path and use the relative filename before building. it was hard to hunt down because I had no clue what was causing the “no disk” msg.
Your standalone is looking for a file at a driveletter that doesn’t exist on the running system, i would say.
O.

#226715
Apr 8, 2012 at 1:12am

Sounds like a good place to start looking – Thanks for your help!

#226716

You must be logged in to reply to this topic.