Connecting with cable

Jun 29, 2013 at 10:47am

Connecting with cable

We are working on using the ipad with MAX but have problems with that the communication betweeen MIRA and the computer is slow on loading new patches, tags we have created etc.

Was thinking that a connection over a cable might be faster, but is that possible in any way?

#254479
Jun 29, 2013 at 11:07am

Unfortunately a cable connection is not possible at the moment. Apple is pretty restrictive about what you can and cannot do with an iPad over USB. But don’t worry, we’re aware that Mira can be a bit slow when loading patches and we’re working on making it faster.

#254481
Jun 29, 2013 at 12:37pm

That’s good to know, looking forward to that. See that it’s working faster trough a wifi router instead of the adhock solution, but still need to optimize it.

#254485
Jun 30, 2013 at 6:18am

well, there’s one potential solution that would allow the use of a USB connection instead of wifi : it’s called MyWi

http://intelliborn.com/mywi.html

…ok, it requires a jailbroken device… but seriously, I use it all the time with Lemur, Fantastick, TouchOSC, … and it’s much, much faster and reliable and easy to use than wifi !

Unfortunately, it actually doesn’t seem to work with Mira…
I guess that’s because Mira is looking for the wifi network’s name before trying to connect to the computer (or something like that..)
I never encountered such problem with other apps that require network connection, probably because they just don’t care about the network name or kind.

So please, please register this as a feature request !!!
Let Mira work thru MyWi !
(does Mira really needs to display the name of the wifi network ? can’t it just use the currently available connection, as other apps do ?)

#254544
Jun 30, 2013 at 3:12pm

joining that call for a cable solution, and hope something can make MIRA faster before tuesday at 14.00

#254567
Jul 1, 2013 at 12:51am

about MyWi :
actually, using MyWi instead of WIFI connection : Mira can see my Max Server, but as the top-left pane says “Current WIFI : Not Connected”, the “connect” button beside my host name is greyed (inactive).
(as in Mira preferences / Linked)

…it *almost* works !

#254583
Jul 29, 2013 at 8:40am

+1 for making it work with MyWi

#257482
Aug 27, 2013 at 6:08am

Why not implementing MIDI so it can be used with a USB-MIDI adapter like ik multimedia iRigMIDI?
I think it would be simpler, and especially people who are using the iPad in the studio (as an external sound module with Animoog and so on) like me, usually already have an iOS MIDI card.
Thanks.

#260044
Oct 24, 2013 at 11:16am

MyWi does work with MIRA..
This does not work in AdHoc mode.
Log on to WiFi network with iPad, run MyWi, turn off WiFi on receiving computer, plug cable in from iPad and turn on USB tethering.
Works for me.
Bill

#269022

You must be logged in to reply to this topic.