Forums > MaxMSP

Could not find framework class com/cycling74/max/MaxObject


ufk
November 5, 2013 | 12:39 pm

Hello.

I’m using Max 6.1.5 with a Max for Live patch using
Ableton 9.1b26 on OSX 10.9.

it seems that Max for live won’t load any mxj patches that I have!
the only difference that I remember since the first time I encounter the problem was that I upgraded my OSX to 10.9, the problem did not occur before.

I read many posts in this forum that suggests re-installing stuff, checking hard drive for errors, checking permissions… I did all that and nothing changes. I just use ‘mxj name’ when a class that doesn’t exist but I still get

Could not find framework class com/cycling74/max/MaxObject

any ideas ?


November 5, 2013 | 3:20 pm

Hello,
Are you using German for your computer’s language? We have had one other report of this in support. At the moment we have no idea what is causing it.

Cheers

-A


November 5, 2013 | 3:37 pm

If you open a default device for editing are you able to open an example patcher like 01.mxj~noise.demo from the mxj~ examples folder in the Max editor?

Does Java work ok on that computer in other apps?

If you change to the other architecture does anything change? From 64bit to 32 bit or vice versa.

If you like, send us the details in support

Cheers

Andrew



ufk
November 6, 2013 | 1:34 am

my computer language is english and i can’t open any mxj~ demos.

my java:
# java -version
java version "1.7.0_45"
Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)


November 6, 2013 | 7:09 am

I’m the other report
I found out that the problem only appears if max runs in 64bit mode.
Try Ableton 32bit so it starts max in 32bit.
Didn’t really solved my problem because somehow my maxpatch doesn’t like 32bit =/



ufk
November 6, 2013 | 9:26 am

i can confirm that the problem does not occur on 32 bit of ableton.



Lee
January 6, 2014 | 12:31 pm

.


January 6, 2014 | 12:34 pm

Just write to the cycling Support and refer to this threat they’ll help you ;)


January 6, 2014 | 12:37 pm

Everybody please make sure you are using Max 6.1.6 and that Java is otherwise installed correctly on your computer.

Lee – maybe try a reboot? Or blow away Max and reinstall etc

-A



Lee
January 6, 2014 | 12:39 pm

Yup, just done that Andrew and it’s cleared up… thx


Viewing 10 posts - 1 through 10 (of 10 total)