Forums > Max For Live

CPU usage 38% with just my patch at MAX

September 20, 2013 | 2:42 am

Hi,
i’ve got a i7 with 16gb RAM working with 64bits W7.

I just made my very first patch, which is a complete syntheziser, 2OSC, modulations (AM,FM), Inserts effects, GLobalFX(Flanger,Chorus,etc.), Routing Envelopes&LFO’s to most parameters…

well..
When I "copy paste" all my patch to an .amxd extension, so live can use my synth, then I save it. And I add it as MAX INSTRUMENT.

Just on basic I get like 38% CPU ussage from live, while from Windows admin Resource I don’t get that much of CPU usage, if I keep on duplicating that MIDI INSTRUMENT, once I reach to 2 or 3… CPU USAGE from Ableton is like 98%…

I’ve tryed to debug and see the option of SHOW CPU USSAGE from MAX…but the only objects that consume 4% of the CPU is poly~ and pfft~ …. which I have 4 of them…

Is it my patch that its not optimized??
Or there is some kind of problems of optimization once it gets down to ableton with MAX4LIVE???

Thanks for your help and time.

I add the complete patch, the "main.maxpat" is the main to open it with MAX
SyntheNDREK01 is a version for MAX4LIVE
SyntheNDREK02 is a version for MAX4LIVE, but all parameters are shown horizontally without having to open MAX4LIVE to edit the sound (I did so to try and use less CPU…FAILED…obv.. )


September 20, 2013 | 3:42 am

You haven’t attached your patch but pfft~ can be pretty expensive in terms of computation. Are you muting the poly~ objects/voices correctly when they are not in use? There are many ways to optimise but please add your patch (as attachment is better with a folder with abstractions)


September 20, 2013 | 8:21 am

edit: main file is at the end (had some troubles…sorry for newbie..)


September 20, 2013 | 8:48 am

I believe you can attach Zip files? Best to put them all in a folder and zip that I would think. Also saving everything in a ‘project’ (only in MAX6) is a good way to keep all the relative files together and have MAX find them easily on other computers. This makes sharing simpler.


September 20, 2013 | 10:08 am

hmm let’s try zip…but .rar didnt.. ^^’

wow zip does accept
pd: everything is in this file. the max4live device, and the max version. Both consume tons of CPU!!

Attachments:
  1. SynthENDREK.zip

September 20, 2013 | 10:18 am

also, for us to test your maxforlive device, why not just attach that? So we can get to it without expanding archives and sorting through stuff? :)


September 20, 2013 | 3:25 pm

because the maxdevice or the main.maxpat, has some patches that need to be added. Is there a way to add them, as the "copy compressed" way ?? Or "embeed code to bpatcher" way??


September 21, 2013 | 1:19 am

were you able to make it work correctly??

thanks in advance for your help and time.


September 23, 2013 | 9:46 am

did anyone run it? and mesure cpu ussage???

thanks for your help and time.


September 24, 2013 | 3:48 am

ye sit consumes cpu, but it’s big so… maybe try to get rid of some vizualisations, i’m not sure but maybe the jitter stuff mught be consuming cpu too.
If you have poly~ and fft~ multiple times, they might consume a lot. You might want to use the @parallel 1 attribute in poly to distribute cpu charge over multicore (but it doesn’t seem what’s taking the most). But audio status window shows 69 signals used and 823 function calls, which is a lot, so it’s not really surprising that this patch consumes htat much cpu. And you’re using sends~ and receives~, max window shows that receives~ consume a lot of cpu. Also cos~. And your poly~ and fft~ do consume a lot too. And snapshots~ ! Maybe if you try doing some stuff inside gen~ ? and replacing unnecessary send~/receive~ pairs by patchcords, and doing some calculations in gen~ if possible.


September 24, 2013 | 1:57 pm

don’t have gen~ upgrade…..maybe its time for it? :P

will it improve much??

patchcords, you mean like matrixcntrl~ and things like that??

One of my biggest issues how to optimize sending the signal to InsertsFX pre/postfilter and to the final FX section… using the send~/receive~

Also, I’ve got like kind of a DC noise….under everything…if I have all my patch off, no waves,etc, just DSP on, and playa key, you can hear "click/boom"

spectroscope~: 0.64% of total CPU
spectroscope~: 0.64% of total CPU
spectroscope~: 0.64% of total CPU
spectroscope~: 0.64% of total CPU
spectroscope~: 0.64% of total CPU
cycle~: 0.67% of total CPU
spectroscope~: 0.67% of total CPU
spectroscope~: 0.69% of total CPU
pow~: 0.69% of total CPU
spectroscope~: 0.69% of total CPU
spectroscope~: 0.70% of total CPU
spectroscope~: 0.71% of total CPU
spectroscope~: 0.71% of total CPU
spectroscope~: 0.77% of total CPU
spectroscope~: 0.83% of total CPU
spectroscope~: 0.90% of total CPU
spectroscope~: 1.07% of total CPU
spectroscope~: 1.19% of total CPU
pfft~: 2.84% of total CPU
pfft~: 2.89% of total CPU
poly~: 3.52% of total CPU
poly~: 3.66% of total CPU


Viewing 11 posts - 1 through 11 (of 11 total)