Forums > MaxMSP

Crash on New From Clipboard, XP

October 14, 2008 | 9:51 pm

Hey guys, wondering if someone has come across this problem and found a fix. One of my students is having Max crashes whenever he does new-from-clipboard in Max 5.0.5

He has trashed his preferences, reinstalled, defrag’d, etc.

Opening full patchers works fine – no trouble. *JUST* new from clipboard. His machine specs are below:

1.65gHz Core2Duo Dell Vostro, 2G Ram. Windows XP Home SP3.

-M


October 15, 2008 | 7:15 pm

It would help to know what is on the clipboard. Perhaps your student can paste the clipboard into notepad or an email or something to verify what is there?

Also, another useful experiment would be to see if pasting works properly into the max text window (File -> New Text) and into a plain old patcher.

Here is a nice controlled experiment:
– new patcher
– insert button
– select button
– choose Copy
– choose File -> New From Clipboard

If that works, then perhaps the problem has to do with the way the patcher contents are copied to the clipboard so perhaps more details can be provided on what software is doing the copying and what is being copied.

Rob


October 17, 2008 | 3:10 am

Aye. Good suggestion.

Class wont meet for a few more days still, so I can’t troubleshoot myself but it would seem from afar that simple patches are loading fine. Metro to a counter to a number box, etc.

Pasting works fine into a text file. And pasting does not work in a plain, empty patcher window.

Tried going from his email to Max, email to text edit to max. Complex patches still crash on new from clipboard. Either way, I’ll see if we can narrow it down to a problem with specific MSP objects, Jitter objects, or what.

-M


October 20, 2008 | 4:52 pm

If you have some patchers that reliably cause crashes on New From Clipboard I wouldn’t mind seeing if they crash on my windows install.

Thanks,
Rob


October 20, 2008 | 5:07 pm

Hey Rob. Thanks.

I’ve tried opening these on my Windows machine with nary a problem, but who knows. This one is just a simple gl.Nurbs patch – almost exactly the help file. Crashes without fail on the student’s machine.

I haven’t heard back from the student for a couple days – so maybe he figured it out, but I’m curious to find out if anyone can reproduce the problem.

-M

– Pasted Max Patch, click to expand. –

October 20, 2008 | 5:40 pm

Unfortunately that patcher doesn’t crash for me on New From Clipboard. Thanks for trying.

Rob


Viewing 6 posts - 1 through 6 (of 6 total)