crash upon loading patches with feedback textures

Apr 6, 2009 at 10:37pm

crash upon loading patches with feedback textures

jit.gl.texture: error entering unbind: GL Error: Invalid value

Ive been getting this error when I load patches that ive made with totexture+usetexture style feedback rendering. I find that I have to open the patch as text and rename the feedback texture and then it works, and as soon as I close + re-open it, it crashes again, typically the crash happens after the patch is totally loaded and on the screen but not yet running and as soon as I click on any of the windows it dissapears without giving the typical mac osx crash dialogue

Im running osx 10.4.11 and latest max/jitter on a macbook pro 2.16 2gb ram w radeon x1600 256mbvram

#43243
Apr 6, 2009 at 10:39pm

jpatchline_completeconnection: index out of range.

jit.gl.shader: unable to bind GLSL uniform param: ‘tex0′

there were a couple other errors but I dont know if these affect the crash as I have had other patches that crash but didn’t have these errors.

#155090
Apr 7, 2009 at 8:16pm

as always, posting a simple patch helps us track down the problem

#155091
Apr 8, 2009 at 4:56pm

unfortunately Its not something I can post, and all the small demo ones to try and replicate the thing dont crash, it doesn’t make any sense…. Ill try to find something that I can post but not sure right now what to do.

#155092
Apr 9, 2009 at 2:22am

if someone thinks that they can help me I will send them patch off list, I cant send to the open forum because its a large installation project, but to someone specifically i will send.

#155093
Apr 9, 2009 at 4:25pm

I think I fixed it, in case anyone else ever has this problem, what I did was I had to take out my autopattrs because they were loading settings before the texture for feedback was loading or something like that, and it would sometimes crash and sometimes not… I just took them out and it seems to work fine.. kinda sucks that I cant use autopattr with feedback textures Sad

#155094

You must be logged in to reply to this topic.