Forums > MaxMSP

crash with record~ to buffer~

February 7, 2006 | 11:20 am

I am getting a consistent crash with the following patch. I did not see anything in the record~ documentation about why this patch should be problematic.

OS X 10.4.4 MaxMSP 4.5.6

Eric

#P toggle 58 86 15 0;
#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P message 146 102 37 196617 loop 1;
#P user ezdac~ 32 201 76 234 0;
#P newex 33 40 88 196617 cycle~ 689.0625;
#P newex 33 136 74 196617 record~ oscar;
#P newex 33 171 120 196617 buffer~ oscar 1.451247;
#P window linecount 4;
#P comment 136 244 200 196617 Sometimes Max crashes immediately. Other times you have to either turn off DACs or close the patcher and then Max crashes.;
#P window linecount 1;
#P comment 190 101 100 196617 1. enable looping;
#P comment 86 206 100 196617 2. turn on DACs;
#P comment 59 71 100 196617 3. start recording;
#P connect 6 0 5 0;
#P connect 8 0 5 0;
#P connect 9 0 5 0;
#P window clipboard copycount 10;


February 7, 2006 | 12:04 pm

probably related to sigvs longer than rec-loop length.
try with 32 and i bet it will work.
kind of logical but still it should be mentioned somewhere.
best
volker.


February 7, 2006 | 12:26 pm

Quote: vboehm@gmx.ch wrote on Tue, 07 February 2006 12:04
—————————————————-
> probably related to sigvs longer than rec-loop length.
> try with 32 and i bet it will work.
> kind of logical but still it should be mentioned somewhere.
> best
> volker.
>
>

Thanks for the suggestion. This appears to be correct, and perhaps related to the limitations of tapin~/tapout~. One might argue that this limitation on record~ should not be necessary. I’ve written externals that record to MSP buffers smaller than the sigvs without crashing.

Eric


Viewing 3 posts - 1 through 3 (of 3 total)