Forums > Max For Live

crashes during edit [Max for Live]

March 6, 2010 | 6:33 pm

Hello.

I have been experiencing crashes in Live during editing. I am not in play mode, and the crashes happen when I save the patch.

However, they don’t crash on the first save, it’s much more random than that – usually around the third or fourth save, but it happens every time; I haven’t had a single session that didn’t crash.

It doesn’t matter if I am editing the default max for live devices, or a downloaded device. Live will crash, and I will only be able to exit max itself by clicking "don’t save" in the dialog box.

Really confused as to what’s going on, I wish I had more specifics but I don’t know what else might be relevant….

Any help would be most welcome, as of now I am dead in the water!

Best, Jeremy


March 6, 2010 | 7:59 pm

Crashes in M4L are not exceptional…
Does it happen also with a new song and a single track?


March 6, 2010 | 9:07 pm

Well, I’ve had a lot of experience with this exact issue, but you’ve haven’t provided any details to comment on. You might look at the crash report and get a sense of what’s causing it, post patch a crash log here, or (best) send the info to support at Cycling.

For me, it was JSUI code that made M4L and Live unhappy…

Charles


March 7, 2010 | 12:24 pm

Hello Charles and Broc,

Yes, I’m aware Im not giving much to go on, but I’m having trouble pinning any one factor down.

Yes, I have tried with a new song and only one track – it still seems to crash. At first I thought it was using csound~ inside of Live, but I tried it just pasting a simple patch into the default "max audio effect" and "max midi effect" – after a few saves Live crashed.

No JSUI here – I’m wondering if it’s where I am keeping my m4l patches – do they have to be in any particular place (other than the max search path)?

Weirdly enough, Live seems to crash without notification of doing so or a crash log most of the time, but next time it does, I will send one in.

Apologies for not being more specific, but it really does seem to crash no matter what I do, albeit unpredictably.


March 7, 2010 | 1:02 pm

I have my m4l devices in the same path as the factory devices, ie. Live8Library/Presets..
Seems to me the most "natural" place, but not sure if it matters.


March 24, 2010 | 1:49 pm

Hey, ive only had m4l since last night and it happened once just then while i was editing a max installation patch im trying to modify to work within live. same thing no crash reporter and wouldnt let me close/restart max until i clicked ‘dont save’ on my patch. Was nothing overly complex a few bpatchers n such but yeh.. sorry i dont have any answers just saying i experienced the same problem.
jake


March 24, 2010 | 5:10 pm

You might check if you have saved a patch using a name tat’s also used by mfl itself. Did you save a patch with a default function name of javascript? Is your system always rockstable, except when running mfl?


Viewing 7 posts - 1 through 7 (of 7 total)