csound~ crashing

Dec 7, 2010 at 9:49pm

csound~ crashing

Hi Everyone,

I’d be very grateful if someone could help me out with this.

I was wondering whether anyone is successfully using csound~ with Max/Msp 5 or MaxforLive on Windows 7 64-bit. I’m using the latest versions of Max and csound~, and have tried both the double and float versions of csound5, but it invariably ends up crashing.

Heres an example crash report:

—————————————————

Problem Event Name: APPCRASH
Application Name: Max.exe
Application Version: 5.1.6.43950
Application Timestamp: 4ce56718
Fault Module Name: libfluidsynth-1.dll_unloaded
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 4a358baf
Exception Code: c0000005
Exception Offset: 6f381364
OS Version: 6.1.7600.2.0.0.768.3
Locale ID: 2057
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

————————————————————–

I can recreate these crashes by starting a .csd file with csound~, stopping it and then opening a new explorer window (ie ‘Computer’ or a desktop folder). Crashes also occur when moving between Ableton and MaxforLive.

Both MaxMsp and MaxforLive are very stable otherwise, so it’s definately related to csound~ somehow.

It will be useful to know whether or not others are having the same problem. Any advice would be great.

Many Thanks

#53798
Dec 8, 2010 at 6:09pm

I think I ran into this problem a while back as well. Basically fluid synth
was causing the problem. I had to remove the fluid synth dll.

#193620
Dec 9, 2010 at 3:49pm

Thanks for the hint Anthony. I moved ‘fluidOpcodes.dll’ from Csound’s plugin folder and this seems to have solved the problem. I hope this workaround proves useful to anyone else having difficulties.

Thanks again.

#193621

You must be logged in to reply to this topic.