Forums > MaxMSP

cubase sx 3, rewire and me crying in the corner!

October 15, 2006 | 4:56 pm

Hello everyone, hope that your all well. I am currently cooking up something using Max/MSP 4.6.2 & Cubase SX 3 with the intention of linking them via rewire. The idea is that I will be triggering various events in Max/MSP with MIDI from Cubase and I hope to use rewire to send these MIDI events. It would then be nice to be able to route Max/MSP’s audio back into cubase and out into the real world. For the most part I will not be looking at the cubase SX window and so would also like to be able to control the transport functions from within Max/MSP. I think that this all sound fairly plausable but I have come across a couple of issues that I hope you can help me with:

1) Cubase can only be used as a Rewire mixer application. Can Max/MSP be used as a synthesizer application and would this work with the set up that I am proposing?

2) When I try to initiate rewire in Max/MSP (i.e through the DSP status ad_rewire option) I get an error message when I start the DAC reading "error: ad_rewire: error starting audio. Is ReWire mixer running?". I find this messaage fairly confusing as it launches both with cubase open and with it closed.

Any ideas? Many thanks….:)


October 15, 2006 | 5:13 pm

p.s when I say "synthesizer application" I mean slave application.


October 15, 2006 | 5:16 pm

open cubase
open max, set audio driver to "ad_rewire"

done.


October 15, 2006 | 5:17 pm

did that, still got the error message.


October 15, 2006 | 5:21 pm

I just looked at it again and the error message only appears when I want to start using hostcontrol~ object within Max/MSP. Any ideas?


October 15, 2006 | 5:41 pm

check to see if "Max" is under Cubase’s devices menu. If it’s not, then Max hasn’t registered as a rewire client. Where to go from there I am not sure. If it IS there, try enabling audio channels 1&2 then starting up Max and trying to turn on the ezdac~ with ad_rewire selected.


October 15, 2006 | 8:16 pm

yeah I did that, I just don’t get it! Does the message indicate that Max/MSP is having difficulty communicating with Cubase?


December 26, 2006 | 6:51 am

I am encountering the same error message while attempting to do essentially the same thing using Logic 7.2

Have you resolved this issue yet?
If so, what was the solution?


December 26, 2006 | 7:12 am

Hmm. I’m not totally sure how I fixed it, but I got ReWire between Max/MSP and Logic 7.2 working fine.

No more "Is ReWire mixer running?" error messages for me.

I basically tried everything you would think would make it work.
Randomly messing with stuff in the environment window, defaulting and resetting all audio/midi driver preferences, etc.
None of that seemed to help.
Then I did the following:
1) Saved my Logic session I was trying to make work.
2) Quit everything. (I actually had to force quit Max/MSP because it hung when I quit Logic
3) Restarted
4) Started Logic first
5) Opened the most recent session I had been trying to make work before
6) Started Max
7) Opened and ran my test patch

It certainly helped that I have been working from the Cycling 74 tutorials on ReWire with Max/MSP

http://www.cycling74.com/story/2006/9/18/121516/485

I hope you already resolved this your issue long ago.
If not, I hope this helps.



Zh
January 15, 2007 | 10:31 pm

I’m having the same problem trying to get max to talk to ableton live, exactly the same error message. Tried all the above, same. Ableton can see Max and all its outputs, max can’t turn on dsp!
Help!


Viewing 10 posts - 1 through 10 (of 10 total)