Forums > MaxMSP

Cycle~ high pitch noise at 0hz?

September 28, 2013 | 6:16 pm

I am a super-beginner at Max.

I’ve made just a simple noise maker with Cycle~, *~, a couple sliders, EZDAC and a meter.

Everything works great when I have saw~ instead of cycle~, the audio is clean.

saw~ at 1 makes a nice ticking sounds as expected. saw~ at 0 is silent.

cycle~ at 1 is a pulsing high pitch tone. cycle~ at 0 is a steady high pitch tone. cycle~ at 440 has the expected 440 tone plus the high pitch noise in the background.

I am wondering if this is a result of the crappy audio card I have in my laptop? Or is this some part of cycle~ that my total newbie status doesn’t grasp yet?
Bad audio card would be no surprise and as I am just learning I have not yet invested in an RME or nice external card yet.

Thanks! Sorry if this is a super-newbie question… the forums are full of stuff so far over my head but I am learning!


September 28, 2013 | 9:31 pm

this shouldn’t happen even with the built-in card. Can you describe the noise a bit better?
How is the CPU usage?
Did you try different sample rates and buffer sizes?
t me this sounds a bit like you are forcing the soundcard in a sample rate that it doesn’t supprort, but that’s a wild guess.


September 28, 2013 | 10:11 pm

The CPU use is very light… My sample rate is 44.1. I’ve not played with buffer sizes yet.

It is interesting though: I put on headphones and this noise is very present. I used the Extras>QuickRecord and while I can see the noise on its meters it doesn’t record. I can hear my audio card struggling to keep up while running my volume fader but nothing of the high pitched tone.


September 29, 2013 | 8:37 am

Have you encountered this behavior in other applications too?
What OS are you using?
update audio drivers?
Are you using ASIO if on windows?

I still doubt that the soundcard is broken or just crappy, although it sounds like.
There are really cheap soundcards out there (10 bucks, eg. http://www.conrad.at/ce/de/product/994000/Speedlink-USB-20-Mini-Soundkarte).
They can be quite crappy too though.(low SNR, lots of aliasing)

You could try one of these before investing in a great expensive product too soon just because of these unusual problems. But I still guess it’s a software issue.


September 29, 2013 | 8:38 am

And again, try vector size 128 IO vector size 128 eg.



dtr
September 29, 2013 | 10:23 am

0 or 1 Hz would result in a DC signal on the outputs. Sounds like the soundcard freaks on that.


September 29, 2013 | 11:24 am

Have you encountered this behavior in other applications too?
No… nor have I seen this in downloaded patches.

What OS are you using?
Windows 7/64

update audio drivers?
I’ve tried both the HP provided drivers and the card maker’s generic driver, same results.

Are you using ASIO if on windows?
No ASIO… I’m not sure the onboard card would support that but won’t hurt to try!! Audio Status reports ad_mme for the driver.

I will try the Vector size when I get back to my laptop…

Thanks for all the input you guys are great!


September 29, 2013 | 11:34 am

I changed my audio driver from mme to directsound and its much much better. I still get static noise as I run my volume slider up and down, sounds almost like a tiny hit every time it crosses a step.

My volume slider for my cycle~ is very noisy…
I am using a basic slider to control volume. Range 1, min 0, max 1, float.
I get static noise across the entire fader as I ramp volume up and down.

I only get the popping sound in the range from 0-1. If I increase my range and max to 2 I get popping on one half of the silder… once it goes above 1 I get no more popping.

If I disconnect the line from the cycle~ to my *~ and run my volume slider I get no noise. Somehow the combo of cycle~ and the volume slider is creating pops at every increment.

My volume slider for my saw~ is very clean! No noise at all…

I may need to make a new thread about this.

Thanks for all the help!


September 29, 2013 | 12:32 pm

My volume slider for my cycle~ is very noisy…
I am using a basic slider to control volume. Range 1, min 0, max 1, float.
I get static noise across the entire fader as I ramp volume up and down.

use live.gain~


September 29, 2013 | 12:46 pm

yeah, any gain slider will produce clicks when the audio is a 1 Hz sinewave and you dont do interpolation on the slider.

live.gain~ or [line~ 40.] will be of help here.

but the noise you get when cycle is at 0 Hz should be an issue with the driver, driver setting, or soundcard. (bugs like that can also sometimes happen while patching, where then a simple audio restart usually removes it back to normal.)


September 29, 2013 | 2:21 pm

I obviously have a lot to learn! I literally just started with Max after working with a live performance built using Live and Touch Designer. I’ve been using Touch Designer a lot so the Max way of programming is at least semi-familiar and I figured I could teach myself. Its proving to be a challenge, but a lot of fun.

I’ll have to look up what "interpolation on the slider" means.

Thanks for the tips/help!


September 29, 2013 | 3:07 pm

I’ll have to look up what "interpolation on the slider" means.

Just know that live.gain~  will do that for you, but you will always have some issues if your oscillators are set to 0 hertz.


September 29, 2013 | 6:16 pm

interpolation means in this context nothing more than in most others.

see, if you move a GUI object with the mouse, the data this produces is not even close to the resolution of audio.

so this produces clicks and pops, which are not hearable when playing music, but you hear them quite good when there is only a 1 Hz cosine, because you dont hear the cosine at all in this case. you hear only the gain change you do to it. :)

the audio slider and the live object can perform interpolation when you tell them to, but if you are coming from numbers, like multislider produces them, you need to interpolate using line~, somewhere in the range of 15-50 milliseconds.


Viewing 13 posts - 1 through 13 (of 13 total)