Forums > Jitter

delay caused by sending movies through the router?

September 6, 2006 | 1:21 am

Hi,

I was wondering if any delay could be caused by sending my movies through a router object. Below you can find an example patch of what i’m trying to do.
I use this ‘routing technique’ throughout my patch, e.g. for dynamically selecting sources or ‘snapping on’ different optional effects and filters.

I believe that this technique could be one of the problems in my patch causing a lower framerate. So you probably hear me coming already,… is this a good technique? Or are there better (best) practices for doing this kind of dynamic ‘routing’?

thanks in advance
david

#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P newex 192 99 60 9109513 prepend rate;
#P flonum 192 81 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P user matrixctrl 67 131 51 50 MatrixDefaultCell.pct MatrixDefaultBkgnd.pct 51 50 16 16 3 3 16 16 1 1 49 2 5120 0;
#P newex 67 191 589 9109513 router 3 3;
#P user jit.fpsgui 82 257 60 9109513 0;
#P newex 67 222 396 9109513 jit.glue @columns 3;
#P message 723 117 26 9109513 stop;
#P message 690 117 26 9109513 read;
#P window linecount 2;
#P newex 646 149 172 9109513 jit.qt.movie 640 480 @colormode ayvy @loop 0;
#P window linecount 1;
#P message 530 118 26 9109513 stop;
#P message 497 118 26 9109513 read;
#P window linecount 2;
#P newex 453 150 172 9109513 jit.qt.movie 640 480 @colormode ayvy @loop 0;
#P window linecount 1;
#P message 363 118 26 9109513 stop;
#P message 330 118 26 9109513 read;
#P newex 260 74 45 9109513 metro 33;
#P toggle 260 49 15 0;
#P window linecount 2;
#P newex 260 150 175 9109513 jit.qt.movie 640 480 @colormode ayvy @loop 0;
#P connect 2 0 0 0;
#P fasten 2 0 5 0 265 141 458 141;
#P fasten 2 0 8 0 265 141 651 141;
#P connect 14 0 13 0;
#P connect 13 0 11 0;
#P connect 15 0 16 0;
#P connect 1 0 2 0;
#P connect 16 0 0 0;
#P fasten 3 0 0 0 265 135;
#P fasten 4 0 0 0 368 141 265 141;
#P connect 0 0 13 1;
#P connect 13 1 11 1;
#P fasten 6 0 5 0 458 135;
#P fasten 7 0 5 0 535 141 458 141;
#P connect 5 0 13 2;
#P connect 13 2 11 2;
#P fasten 9 0 8 0 651 134;
#P fasten 10 0 8 0 728 140 651 140;
#P connect 8 0 13 3;
#P fasten 11 0 12 0 72 249 87 249;
#P window clipboard copycount 17;


September 6, 2006 | 2:22 am


September 6, 2006 | 10:09 am

Thanks!

I know i’m not stopping the movies i’m not using in the small patch i posted, but this is because i cut it out of the larger patch that i’m working with.


Viewing 3 posts - 1 through 3 (of 3 total)