[delay] doesn´t work. ja ja ja!!!

Mar 7, 2010 at 3:55pm

[delay] doesn´t work. ja ja ja!!!

hello all,

I laugh at my self, but I don´t get el] to make it´s work. this is my problem:

I press [button] to send [whatever] message to my [c74] object after 5 seconds. well… I make it using [del 5000] and I can see with my eyes how the bang is received by the [button] object conected to my [whatever] message, but the message is not received by [c74] (even when the max window will print it ussing [print]),

but if I click the [button] conected to [whatever] message box manually it will be received by [c74] with no problems.

why [del] is not able to make a so simple task, the task it´s made for??

thanks a lot for your caritative help and responses.

llllllllllllllllllllllllllllll
http://www.davidfernandez.org
llllllllllllll
llllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll

#48979
Mar 7, 2010 at 6:47pm

delay is only capable of delaying one bang. If you want to delay any other type of message, have a look to the pipe object.

#175924
Mar 7, 2010 at 6:56pm

yes!! of course. I´ve been using max for 4 years… as I explain I´m just trying to delay a bang!
but the bang only works correctly when I click on it, not when delayed with [del].

#175925
Mar 7, 2010 at 7:13pm

could you post a patch? It might be an issue with c74 object though, in this case you might want to contact Leo directly.

#175926
Mar 7, 2010 at 9:52pm

Judicious use of a [defer] object may help. Without a patch it’s really hard to say.

#175927
Mar 7, 2010 at 9:55pm

And, by the way, if you can print your message that’s driven from the delay to the Max window, it’s certainly not delay’s fault.

#175928
Mar 7, 2010 at 9:57pm

ey chris muir!!! thanks a lot!

[defer] object has fixed up the problem!!
I always say I can´t value the help sometimes I get from this forum… thank you very much!!!

llllllllllllllllllllllllllllll
http://www.davidfernandez.org
llllllllllllll
llllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll

#175929
Mar 7, 2010 at 10:23pm

if defer does the trick you might want to send an email to Leo, as it’s likely to be an issue with the c74 object.

#175930
Mar 7, 2010 at 10:39pm

I´ll do so.
and thanks a lot again.

llllllllllllllllllllllllllllll
http://www.davidfernandez.org
llllllllllllll
lllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll

#175931

You must be logged in to reply to this topic.