delay: no such object

Sep 6, 2010 at 6:45am

delay: no such object

i just opened a patch that worked fine a few days ago and my delay objects are now apparently objects of my imagination. i opened the delay.maxhelp patch and got the same “delay: no such object” message. what happened? yes, i am noob.

thanks,
john

#52117
Sep 6, 2010 at 7:02am

the usual cause of this is if you have created a patch or abstraction of your own, and named it ‘delay’. If so, save the file under a different name and delete the old one.

If not, you may need to reinstall Max

#187235
Sep 6, 2010 at 4:51pm

thanks for the response. i haven’t named anything “delay” but i have recently downloaded patches off the max objects database. i’ve trashed them all and reinstalled max, but the problem persists.

#187236
Sep 6, 2010 at 5:11pm

Check that there isn’t an external patch or object or anything in the Max filepath called ‘delay’; other than that, unless someone else chips in, you should maybe contact support.

#187237
Sep 6, 2010 at 7:45pm

fixed! i dragged delay.mxo out of the max-externals folder and dragged it back in and now max agrees that it does, in fact, exist.

thanks,
john

#187238
Sep 6, 2010 at 9:05pm

glad to see you figured it out…
for future reference, also remember that if you have an object/abstraction/file named, ‘del’ within the Max search path, that will also interfere with registering any ‘delay’ objects(‘del’ is the shorthand name for the ‘delay’ object; never name anything of your own creation, ‘del’ or ‘delay’ or any other name or shorthandname already used by other objects such as ‘trigger’, ‘t’, ‘delay’, ‘del’, etc.).

_______________________________________
*Never fear, Noob4Life was never here!*

#187239

You must be logged in to reply to this topic.