Digital audio I/O problem via ADAT

Feb 24, 2009 at 11:00pm

Digital audio I/O problem via ADAT

Hello,

Have tried a number of methods to solve an issue without sucess in Max/MSP 4.6.3

I need to use Max/MSP for real-time spatial encoding, which is easy, so no problems there, the issue is how I have chosen to work.

Have two computers running, one hosts a DAW and an RME RayDAT card.

A second computer is running Max/MSP and also hosts a RayDAT card

I would like to create a digital audio loop using ADAT so that audio is streamed from PC1 to PC2, is processed in Max/MSP, and is then streamed back to PC1 where it is received by the DAW.

There does not appear to be an object explicity designed for routing an external digital audio source into Max/MSP, analog yes, but digital no.

Have tried adoutput~ but it is not responding to the ADAT signal, have checked all input channels, but there is nothing doing. I’m presuming this has to do with the architecure of the RME RayDAT as it is not really a soundcard in the typical sense of the word.

Have looked online, have checked Max object database, but found nothing. Am aware of Sunflower and Jack, but I’m using XP here. It would be possible to switch to hosting Max on a Mac, if that offers a solution using ADAT, but would rather not have to.

I would appreciate any feedback others may have, particluarly if you have solved this problem, or know of a possible solution.

And, in case it is suggested, I am aware I could do this effectively, using one PC running both programs, but that is not what I want to do here.

Thanking anyone who has something to offer in advance!

best

d

#42505
Feb 25, 2009 at 12:32am

you need to use adc. As the arguments you enter the adat channels, on my RME multiface these are 9 – 16 (i.e. [adc~ 9 10 11 12 13 14 15 16]

do your processing, then use the dac~ 9 10 11 12 13 14 15 16 to send the audio back to your PC1.

adoutput accesses the audio stream send to your audio card, i.e. to record the output from max, it is not an object to send the audio to an audio interface.

#152081
Feb 25, 2009 at 1:11am

Hi, thanks, but I tried adc~, am aware of the standard I/O objects,
did not work with adc~, hence trying adoutput~ because I presumed any data routed through the card would be accessible for re-routing through max, leaving again via an dac~ will take another look at adc~ but pretty sure it’s not happening.
best
d

#152082
Feb 25, 2009 at 8:53am

does this connection work in another program? do you have totalmix from RME to check signals?
are they synced properly? what are your digital settings.

S

#152083
Feb 25, 2009 at 9:18am

Yes, DAW to DAW connections function properly. Totalmix on PC1 displays the appropriate output signal, and this is mirrored by totalmix on PC2, but the input is not yet being detected by Max. Am going to go through it step by step, input by input, again, to see if perhaps something has changed after another restart, but I doubt this will alter anything.
thanks
d

#152084
Feb 25, 2009 at 9:44am
Quote:
There does not appear to be an object explicity designed for routing an external digital audio source into Max/MSP, analog yes, but digital no.

There is no distinction between digital and analog sources. A driver hands the audio to max. The adc~ does not the actual analogue to digital conversion. Maybe the object should be named audioin~.

Quote:
Have tried adoutput

That is for capturing the output. Have you opened the dsp status window? From there you can check the driver setup and the i/o mappings. Once again, it is the driver that hands all channels of audio to max. There is where you need to solve it.

_
johan

#152085
Feb 25, 2009 at 10:03am

Thank you Sebastian and Johan for the input,

typical of my experiences with music technology, this morning, having stepped through the same connections, rebooted, again, the adc~ is now registering input!! last night I had given up.
Perhaps it was simply a question of the order in which the various steps were taken.

Sorry for the time wasting on this.

Cheers

d

#152086

You must be logged in to reply to this topic.