Forums > Jitter

disable gpu based objects

June 15, 2008 | 5:38 pm

hello everybody!
i’m trying to speed up one of my patches again…

does anyone know how to disable GPU based objects like jit.gl.slab if they are currently not in use?

on the CPU it’s easy: you simply don’t send a matrix through the object, so you get higher performance.
i tried the same with jit.gl.slab (op) but it doesn’t work, there is no performance difference.

thanks for help!
philipp.


June 16, 2008 | 8:59 am

obviously this question is too easy… :( no answers…


June 16, 2008 | 12:25 pm

pleeeeeease! help, i need to finish my patch! where are the masters?? vade, david and friends?


June 16, 2008 | 1:41 pm

just exclude them from your rendering chain with a switch or gate
object works ok.

On Jun 16, 2008, at 2:25 PM, expjektor wrote:

>
> pleeeeeease! help, i need to finish my patch! where are the
> masters?? vade, david and friends?

Telcosystems
PO box 174
3000 AD
Rotterdam
http://www.telcosystems.net
info@telcosystems.net


June 16, 2008 | 4:27 pm

What do you mean by disable? Would a switch or gate work for what you are trying to do? Are you processing really large textures or using multi-sample shaders (blurs, cf.shaders, etc.)? Most likely, if you aren’t noticing any improvements when removing jit.gl.slab from the rendering chain, then that is not your bottleneck. Look elsewhere in your patch. If you are having trouble getting your patch to perform at appropriate speeds, you can post your patch up here and see if anyone can offer suggestions.

Best,
Andrew B.


Viewing 5 posts - 1 through 5 (of 5 total)