Disabling "Updating Database…"

Apr 18, 2010 at 1:53pm

Disabling "Updating Database…"

Hello,

I am developing a Max/JS project that requires extensive rebooting of Max for debugging puposes. I use Apache ANT to copy files into the Cycling ’74 folder and relaunch.

Invariantly, some moments after startup, Max will begin the background operation called “Updating Database…”, which eats a lot of CPU and is otherwise annoying. I guess this operation has to do with the File browser database?

Can I disable it someway? I realize I could use the runtime, but this is not an option as I often need to move objects around in my debug patch and want to use the Send message… functionality to send messages to my main js object.

Any help would be greatly appreciated!

#49836
Apr 19, 2010 at 2:46pm

[Bump] Anyone?

#178962
Apr 19, 2010 at 7:38pm

You can remove the sqlite.mxo from Max5/Cycling74/extensions, but you might find that you aren’t able to do some other things that you might want to do.

Also/alternately, you an create a text file containing the following:

max db.disable 1;

Save with any filename ending in .txt into Cycling ’74/extensions

This should disable the database on load.

-Ben

#178963
Apr 19, 2010 at 11:21pm

Thank you, I’ll disable the database temporarily.

#178964

You must be logged in to reply to this topic.