Displaying jpg images in LCD…

Feb 11, 2008 at 3:13pm

Displaying jpg images in LCD…

Don’t quite know what im doing wrong here but LCD wont display any jpg images. Im sure my message boxes are set up correctly and my jpg files are in the Max search path. Any help always appreciated

max v2;
#N vpatcher 145 151 1268 808;
#P origin 21 11;
#P button 822 21 15 0;
#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P newex 591 276 60 196617 loadmess 1;
#P number 681 544 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P number 636 544 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 681 519 27 196617 +;
#P newex 636 518 27 196617 +;
#P newex 591 320 62 196617 metro 200;
#P number 681 458 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P number 636 458 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 591 421 193 196617 mousestate;
#B color 5;
#P toggle 591 299 15 0;
#P newex 719 173 40 196617 unpack;
#P newex 592 227 350 196617 if $i1>=0 && $i1< = 20 && $i2>=0 && $i2< = 20 then open else out2 close;
#P message 414 318 58 196617 8 3;
#P newex 414 297 61 196617 prepend set;
#P message 856 157 84 196617 idle 1 , pensize 0;
#P newex 769 21 48 196617 loadbang;
#P newex 769 48 40 196617 t b b b;
#P message 833 135 146 196617 drawpict flute01 0 0 128 128;
#P message 830 114 139 196617 drawpict pattern flute01.jpg;
#P user lcd 17 23 543 253 1 1 1 1 1;
#N vpatcher 154 186 354 386;
#P origin 15 31;
#P window setfont “Sans Serif” 9.;
#P window linecount 1;
#P newex 166 75 66 196617 pack 0 0 0 0;
#P inlet 269 4 15 0;
#P inlet 221 1 15 0;
#P newex 268 33 37 196617 + 200;
#P newex 220 33 37 196617 + 200;
#P message 202 105 190 196617 window size $1 $2 $3 $4 , window exec;
#N thispatcher;
#Q end;
#P newobj 175 155 61 196617 thispatcher;
#P hidden newex 28 64 94 196617 bgcolor 256 256 0;
#P hidden inlet -1 67 15 0;
#P window setfont “Sans Serif” 14.;
#P comment 1 16 157 196622 check my magic flute;
#B frgb 232 0 201;
#P connect 7 0 9 0;
#P connect 4 0 3 0;
#P connect 8 0 9 1;
#P connect 5 0 9 2;
#P connect 9 0 4 0;
#P connect 7 0 5 0;
#P connect 6 0 9 3;
#P connect 8 0 6 0;
#P pop 1;
#P newobj 738 295 57 196617 p :);
#P newex 738 275 47 196617 pcontrol;
#P comment 572 95 199 196617 check in the left top corner…;
#P connect 8 0 3 0;
#P connect 5 0 3 0;
#P connect 4 0 3 0;
#P connect 3 1 9 0;
#P connect 9 0 10 0;
#P connect 22 0 13 0;
#P connect 13 0 17 0;
#P connect 17 0 14 0;
#P connect 12 0 11 0;
#P connect 14 1 15 0;
#P connect 12 0 18 0;
#P connect 18 0 20 0;
#P connect 15 0 18 1;
#P connect 14 2 16 0;
#P connect 12 1 19 0;
#P connect 19 0 21 0;
#P connect 16 0 19 1;
#P connect 3 1 12 0;
#P fasten 11 1 1 0 937 263 743 263;
#P fasten 11 0 1 0 597 263 743 263;
#P connect 1 0 2 0;
#P connect 18 0 2 1;
#P connect 7 0 6 0;
#P connect 23 0 6 0;
#P connect 19 0 2 2;
#P connect 6 2 4 0;
#P connect 6 1 5 0;
#P connect 6 0 8 0;
#P connect 12 1 11 1;
#P pop;

Stefan

#35756
Feb 11, 2008 at 3:35pm

you need to use readpict before you can use drawpict. Check the LCD help file.

#122265
Feb 11, 2008 at 3:39pm

#122266
Feb 11, 2008 at 3:45pm

Quote: Leafcutter John wrote on Mon, 11 February 2008 15:35
—————————————————-
> you need to use readpict before you can use drawpict. Check the LCD help file.
>
—————————————————-

Still nothing. When i use drawpict first it seems to work (but only with other images). Even the message boxes in the help files don’t load any images when you click them. Could it be an issue with the image file type?

#122267

You must be logged in to reply to this topic.