Forums > MaxMSP

dmxusbpro – only works on 2 DMX channels?


em
October 16, 2013 | 4:13 pm

hello,

i’m using the dmxusbpro object (from nullmedium.de) to run an Enttec DMX usb pro Mk2. with my particular setup i seem to be experiencing an issue whereby DMX information is only sent on DMX channels 1 and 2.

here’s the exact text i conducted (after installing the external and necessary drivers):
1. open dmxusbpro.maxhelp
2. send "menu" message to [dmxusbpro] to populate the umenu
3. choose the item "/dev/cu.usbserial-ENVWHY17" in umenu. this opens the Enttec device
4. open the [fadercontrol] patcher
5. move the position of the sliders. with sliders 1 and 2 the DMX information is sent with no problem. for all other sliders (3-16) no information seems to be sent.

system specs:
MacBook Pro 2.4 GHz 4GB
OSX 10.6.8
MaxMSP v5.1.8
dmxusbpro v1.4
FTDI drivers installed:
both D2XX 1.2.2 and VCP (FTDIUSBSerialDriver) v2.2.18

has anyone else experienced a similar issue and if so, any suggestions for resolving it? i wonder if maybe i’m overloading the bandwidth, i already tried sending message "channels 4" to the dmxusbpro object (because i only need 4 channels), this does not change the behaviour. i know this is not a hardware issue because when i pilot the Enttec using Enttec’s Pro-Manager utility (a tedious test because you have to first remove the VCP driver), i get response on all DMX channels, not just 1 and 2.

thanks in advance!
Emmanuel


October 16, 2013 | 5:36 pm

these is the demo limitation.
if you pay, you can control all channels



em
October 16, 2013 | 10:35 pm

ah ok, that was easy!

thanks very much for clearing that up.
Emmanuel


October 18, 2013 | 4:17 am

look at this !

Attachments:
  1. fxwdmxusbpro.zip


em
October 19, 2013 | 1:42 am

looks great too, thanks for posting!


Viewing 5 posts - 1 through 5 (of 5 total)