Do externals consume much memory when they are not used ?

Sep 6, 2010 at 11:51am

Do externals consume much memory when they are not used ?

Hello,

I have installed several hundreths externals in my Max 5 configuration.

Apart from making the startup duration longer, do these externals use a significant amount of RAM when they are not used ?

Thank you in advance.

#52187
Sep 6, 2010 at 12:08pm

In nearly all cases, if they aren’t loaded into an object, they aren’t using any RAM whatsoever.

#187528
Sep 7, 2010 at 2:58pm

Nope, they are just files until you add them to a patch.

#187529
Sep 7, 2010 at 4:18pm

> “…making the startup duration longer,”

mmh, i didn't even think about that.. Is this the reason why Max takes 4 minutes to launch on my MBP 2,4Ghz ?

[attachment=141019,1094]

Attachments:
  1. Image_6.png
#187530
Sep 7, 2010 at 4:39pm

did u try trashing Preferences folder, then manually re-adding your externals folder to the search path on startup? might help… the Prefs folder tends to fill up and start bogging things down after awhile.

#187531
Sep 7, 2010 at 4:56pm

(wow, Alexandre, that’s pretty much every good 3rd party external you could ever want or need!)

_______________________________________
*Never fear, Noob4Life was never here!*

#187532
Sep 7, 2010 at 6:36pm

> “try trashing Preferences folder”

Thanks, this is faster now. (Although i had weirds messages (on the pic) in max window on the 2st startup. But no more now.)

> ” that’s pretty much every good 3rd party external you could ever want or need!”

Yeah, perhaps i should get some off, as i just really use 5% of them… Would that improve something?

[attachment=141048,1096]

Attachments:
  1. Image_7.png
#187533
Sep 7, 2010 at 7:50pm

By the way, all my patch cords are now black. How can i change the default color for patch cords ?
I did that before but cannot recover how…

#187534
Sep 7, 2010 at 8:09pm

Found it: Options > Object Defaults > “Default Patchline color”

#187535

You must be logged in to reply to this topic.