Forums > Max For Live

does poly~ work inside audio effects in M4L?

August 16, 2011 | 9:42 pm

i am trying to build a live sampling keyboard for record audio on a audio track then playing it back by midi like a keyboard. i have made two patches, one following the poly~ tutorial on cycling 74 youtube. it worked fine as a midi instrument, but then when i tried creating the patch as a audio effect and using send and receive objects to control the pitch playback it got a monophonic synth. i’m confused over why this wont work since i followed everything perfect. thanks.

you need both the patches for it two work this one for the audio channel

– Pasted Max Patch, click to expand. –

and this one for the midi channel

– Pasted Max Patch, click to expand. –

thanks in advance for any help.

cheers
ned:)


August 17, 2011 | 5:39 pm

Well, there are two causes here. Send/receive can come with an x amount of latency so you cannot be sure that one value will be in before the other.

What also strikes me as odd is that you first prepend something to your list, only to use unpack right after it. Even though kslider doesn’t use the "midinote" message.

I’d simply stick to using midiin, add a midiparse object to get the midi data, then simply send out the first outlet’s output to your other patch.

As you can see in the refpage you can then unpack the list in the other patch and that will make sure that both parts of midi data will be processed at relatively the same amount of time.

The second possible cause might be found in the poly~ object. But since you didn’t include the sampkey patcher its impossible to determine.


August 17, 2011 | 6:46 pm

his is the sampkey patcher

– Pasted Max Patch, click to expand. –

your method has worked using midi parse, but i’m confused over how to get
velocity in, and also handle the note off messages, strip note it is i guess.

btw its still mono.


Viewing 3 posts - 1 through 3 (of 3 total)