double speed of the recordings

May 19, 2007 at 4:04pm

double speed of the recordings

Hi,
I am getting videos twice the speed when I record them through
jit.qt.record.
I have done many trials. Starting with the tutorials. It does not
happens with the videos in “media” from the examples. It is happening
with my own videos.
The only strange thing I am doing is that I changed the 320 240 for
720 480 in both the players and the recorder.
I produce my videos in final cut in HDV, render them to dv through
the compressor. I have also tried with videos rendered in mjpegb. I
have tried all type of the lengths.
I include no patcher since it is also happening with the tutorials.
Unfortunately videos are to heavy to send them for you to try them.
My guess is that the reason of this is in my videos.
Any clue will be welcomed. The only time when this does not happen is
when I use jit.vcr and record sound, but the present patcher is too
heavy for this…and I rather sync them afterwards.
I have all the latest max/msp/jitter (beta) and Mac-intel 2GHz and
read the videos form an external HD.
Thanks
Adina

#32180
May 19, 2007 at 4:15pm

>Hi,
>I am getting videos twice the speed when I record them through jit.qt.record.

I’m sure that this is perhaps not necessary, but my first question in a
case where the length of a recorded movie doesn’t match the input
is always “are you sending the “realitime 1″ message and driving your
metros at the speed that matches the frame rate you want? [e.g. metro 33.3]?

on the floor there’s a long wooden table/on the table there’s an open book/
on the page there’s a detailed drawing/and on the drawing is the name I took
Gregory Taylor http://www.rtqe.net

#105391
May 19, 2007 at 4:24pm

try recording with @realtime 1 for jit.qt.record.

On May 19, 2007, at 12:04 PM, [a/izarra] wrote:

> Hi,
> I am getting videos twice the speed when I record them through
> jit.qt.record.
> I have done many trials. Starting with the tutorials. It does not
> happens with the videos in “media” from the examples. It is
> happening with my own videos.
> The only strange thing I am doing is that I changed the 320 240 for
> 720 480 in both the players and the recorder.
> I produce my videos in final cut in HDV, render them to dv through
> the compressor. I have also tried with videos rendered in mjpegb. I
> have tried all type of the lengths.
> I include no patcher since it is also happening with the tutorials.
> Unfortunately videos are to heavy to send them for you to try them.
> My guess is that the reason of this is in my videos.
> Any clue will be welcomed. The only time when this does not happen
> is when I use jit.vcr and record sound, but the present patcher is
> too heavy for this…and I rather sync them afterwards.
> I have all the latest max/msp/jitter (beta) and Mac-intel 2GHz and
> read the videos form an external HD.
> Thanks
> Adina
>

#105392
May 19, 2007 at 6:45pm

On May 19, 2007, at 9:24 AM, joshua goldberg wrote:

> try recording with @realtime 1 for jit.qt.record.

Or if you’re using framedump for non-realtime recording (which I
would *highly* recommend for more steady timing in the output movie,
since realtime recording will have any framerate fluctuations your
patch experiences in real time), be sure to set the framerate of
jit.qt.record to the framerate of the jit.qt.movie instance.

Lastly, if you are using realtime record, use a metro speed that’s
something like the framerate you want to record at or jit.qt.movie’s
@unique 1 attribute to prevent redundant frames being sent through
your jitter network. Otherwise you are recording extra frames, since
jit.qt.record writes to disk every frame it receives.

-Joshua

#105393
May 19, 2007 at 8:43pm

Dear Joshua, Joshua and Gregory:
I used it all: the 33.3 metro for the recorder (number 2 of the
tutorial 19 on recording), the @realtime 1, and the @unique 1 for the
players.
Using only the @realtime 1 was making my patcher incredible slower!
I could not even use the “write”!
I cannot use the dump alternative since I use several presets during
the 2 min. video. I enclose the patcher (which comes form the
recipes!), maybe there is something else to be checked. I still have
to use very small videos (320 180) so it does not slows down…or get
a better computer.
Saludos and thanks a lot
Adina

On May 19, 2007, at 2:45 PM, Joshua Kit Clayton wrote:

>
> On May 19, 2007, at 9:24 AM, joshua goldberg wrote:
>
>> try recording with @realtime 1 for jit.qt.record.
>
> Or if you’re using framedump for non-realtime recording (which I
> would *highly* recommend for more steady timing in the output
> movie, since realtime recording will have any framerate
> fluctuations your patch experiences in real time), be sure to set
> the framerate of jit.qt.record to the framerate of the jit.qt.movie
> instance.
>
> Lastly, if you are using realtime record, use a metro speed that’s
> something like the framerate you want to record at or
> jit.qt.movie’s @unique 1 attribute to prevent redundant frames
> being sent through your jitter network. Otherwise you are recording
> extra frames, since jit.qt.record writes to disk every frame it
> receives.
>
> -Joshua
>

#105394
May 19, 2007 at 8:53pm

On 19 mai 07, at 22:43, [a/izarra] wrote:

> Dear Joshua, Joshua and Gregory:
> I used it all: the 33.3 metro for the recorder (number 2 of the
> tutorial 19 on recording), the @realtime 1, and the @unique 1 for
> the players.
> Using only the @realtime 1 was making my patcher incredible
> slower! I could not even use the “write”!
> I cannot use the dump alternative since I use several presets
> during the 2 min. video. I enclose the patcher (which comes form
> the recipes!), maybe there is something else to be checked. I still
> have to use very small videos (320 180) so it does not slows
> down…or get a better computer.
> Saludos and thanks a lot

As JKC suggested jit.qt.movie’s framedump is the best way to get a
real smooth recorded movie. You can recall some presets during the
recording if you need (jit.qt.movie send out the frame index via the
dumpout output). For more info you’ll have to send the patch or part
of it, otherwise there’s no way for us to help.

Cheers,
ej

#105395
May 19, 2007 at 9:22pm

Hi Adina,

Okay, let me make another suggestion. If you want to have patch
interactivity and can’t (or prefer not to) use framedump, and *don’t*
want the problems of realtime mode, you can do the following–i.e.
operate your patch in “slow motion” to account for the expense of
processing and writing to disk:

1. make your movie playback speed as slow as you need to be able to
record in realtime given an expected framerate. For example if your
*recorded* movies are twice as fast, try setting your *playback*
speed to half as fast, or even better, one quarter as fast to be sure
you can write *every* frame to disk as it is sent through your jitter
patch without dropping any frames.

2. use @unique 1 from your movie output to prevent redundant frames.

3. operate your patcher with the desired changes at a corresponding
speed to match the slow playback speed of your video.

This should let you work with any sized movies and any expensive
patch. You simply need to slow down the playback speed as much as you
need to match the desired output frame rate.

Hope this helps.

-Joshua

#105396
May 30, 2007 at 12:03am

Joshua,

I too am having the non-realtime record patch producing incorrect timings.

I’ve used non-realtime recording for a few years now and it works quite well in the past.

But then all of a sudden, it doesn’t work any longer. I’m not exactly sure what has changed in my setup, but what i do know is that that patch hasn’t changed. I’m using the exact same patch and it records the video double or more. Even stranger it records it several times over.

For example, if I simply open the Jit Tutorial 19, and do the demo as described. My resulting video is correctly 10s long (the same as the original countdown video), but it has recorded the countdown 3 times at triple the speed (metro is off, etc)

I’ve attached the resulting video and below is the patch as text.
The only thing i have changed in this patch is the reduced jit.qt.rec dimensions (halved) so that i can attach the smaller resulting quicktime file. The timing glitch occurs in the original Tutorial patch and this one.

I am running MAX/MSP 4.6.1
Jitter 1.6.1
Quicktime 7.5.1

MAC OSX 10.4.9
Powerbook G4 1.5mHz

As a side note, i do have MAX/MSP 4.5.1 as a folder in my applications folder, does this have anything to do with my problem? Do i need to trash this older folder?

Thanks,
charles

max v2;
#N vpatcher 7 44 860 647;
#P origin 42 46;
#P window setfont “Fixedwidth Serif” 10.;
#P window linecount 1;
#P message 415 599 43 1441802 getfps;
#P message 610 165 43 1441802 getfps;
#P message 295 729 14 1441802 3;
#N counter 2 3 15;
#X flags 0 0;
#P newobj 237 755 92 1441802 counter 2 3 15;
#P newex 264 728 26 1441802 t b;
#P number 302 527 35 10 0 0 0 22 0 0 0 221 221 221 222 222 222 0 0 0;
#P message 251 527 50 1441802 grid $1;
#P newex 239 551 62 1441802 jit.hatch;
#B color 5;
#P newex 477 600 53 1441802 sel done;
#P message 406 472 32 1441802 read;
#P toggle 167 504 15 0;
#P newex 183 503 27 1441802 + 1;
#P newex 167 525 53 1441802 gate 2 1;
#P message 232 452 38 1441802 start;
#P button 174 448 15 0;
#P user jit.fpsgui 333 851 60 1441802 0;
#P window linecount 2;
#P newex 239 608 109 1441802 jit.fastblur @range 2 @mode 5;
#B color 5;
#P newex 239 573 116 1441802 jit.wake @ff 0.6 @fb 0.3 @bleed 0.3;
#B color 5;
#P window linecount 1;
#P message 174 471 62 1441802 framedump;
#P newex 264 661 122 1441802 pack write 15. jpeg;
#P flonum 468 557 39 10 0 0 0 22 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 415 578 38 1441802 sel 1;
#P newex 357 556 68 1441802 unpack s 0;
#P newex 357 534 152 1441802 route read fps framedump;
#P newex 387 707 38 1441802 print;
#P user jit.pwindow 332 726 162 122 0 1 0 0 1 0;
#P message 390 661 32 1441802 stop;
#P newex 264 686 136 1441802 jit.qt.record 160 120;
#B color 5;
#P toggle 355 452 15 0;
#P flonum 395 452 42 10 0.5 0 1 22 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 355 471 50 1441802 metro 2;
#P message 239 471 113 1441802 read countdown.mov;
#P newex 239 501 128 1441802 jit.qt.movie 320 240;
#P window setfont Times 10.;
#P comment 138 445 20 1310730 3.;
#P window setfont “Fixedwidth Serif” 10.;
#P number 496 78 35 10 0 0 0 22 0 0 0 221 221 221 222 222 222 0 0 0;
#P message 446 78 50 1441802 grid $1;
#P window setfont Times 10.;
#P comment 334 6 146 1310730 < - on/off starts and stops recording;
#P window setfont “Fixedwidth Serif” 10.;
#P newex 346 28 50 1441802 sel 1 0;
#P user jit.pwindow 457 126 82 62 0 1 0 0 1 0;
#P toggle 318 6 15 0;
#P newex 674 148 38 1441802 s fps;
#P flonum 346 102 44 10 0 0 0 22 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 346 60 38 1441802 r fps;
#P newex 346 81 53 1441802 !/ 1000.;
#P newex 318 120 38 1441802 metro;
#P newex 459 225 122 1441802 pack write 15. jpeg;
#P flonum 666 124 39 10 0 0 0 22 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 610 144 38 1441802 sel 1;
#P newex 552 123 68 1441802 unpack s 0;
#P newex 552 98 92 1441802 route read fps;
#P newex 434 195 113 1441802 jit.matrix @thru 0;
#P message 614 24 32 1441802 read;
#P newex 582 271 38 1441802 print;
#P user jit.pwindow 458 290 162 122 0 1 0 0 1 0;
#P newex 434 101 62 1441802 jit.hatch;
#B color 5;
#P message 585 226 32 1441802 stop;
#P newex 459 250 133 1441802 jit.qt.record 320 240;
#B color 5;
#P toggle 563 6 15 0;
#P flonum 603 5 42 10 0.5 0 1 22 0 0 0 221 221 221 222 222 222 0 0 0;
#P newex 563 24 50 1441802 metro 2;
#P message 434 24 128 1441802 read countdown15.mov;
#P newex 434 53 128 1441802 jit.qt.movie 320 240;
#P window setfont Times 10.;
#P comment 289 1 20 1310730 2.;
#P window setfont “Fixedwidth Serif” 10.;
#P message 235 26 32 1441802 read;
#P newex 189 172 38 1441802 print;
#P user jit.pwindow 65 193 162 122 0 1 0 0 1 0;
#P newex 38 86 80 1441802 jit.robcross;
#B color 5;
#P message 194 125 32 1441802 stop;
#P message 98 125 92 1441802 write 15. jpeg;
#P newex 66 151 133 1441802 jit.qt.record 320 240;
#B color 5;
#P toggle 167 8 15 0;
#P flonum 224 7 42 10 0.5 0 1 22 0 0 0 221 221 221 222 222 222 0 0 0;
#P window linecount 2;
#P newex 167 26 67 1441802 metro 66.67;
#P window linecount 1;
#P message 38 26 128 1441802 read countdown15.mov;
#P newex 38 66 128 1441802 jit.qt.movie 320 240;
#P user panel 32 1 238 317;
#X brgb 255 127 127;
#X frgb 0 0 0;
#X border 0;
#X rounded 0;
#X shadow 0;
#X done;
#P window setfont Times 10.;
#P comment 14 1 20 1310730 1.;
#P user panel 308 1 409 414;
#X brgb 127 127 255;
#X frgb 0 0 0;
#X border 0;
#X rounded 0;
#X shadow 0;
#X done;
#P background;
#P user panel 158 445 380 441;
#X brgb 255 255 127;
#X frgb 0 0 0;
#X border 0;
#X rounded 0;
#X shadow 0;
#X done;
#P background;
#P fasten 15 0 4 0 240 61 43 61;
#P fasten 6 0 4 0 172 61 43 61;
#P connect 5 0 4 0;
#P connect 4 0 12 0;
#P fasten 12 0 9 0 43 124 71 124;
#P fasten 10 0 9 0 103 146 71 146;
#P fasten 11 0 9 0 199 146 71 146;
#P fasten 9 0 13 0 71 175 71 175;
#P connect 8 0 6 0;
#P fasten 67 0 66 0 188 523 172 523;
#P connect 64 0 60 0;
#P connect 68 0 67 0;
#P connect 9 1 14 0;
#P fasten 46 0 66 1 244 522 215 522;
#P connect 7 0 6 1;
#P fasten 74 0 75 0 269 750 242 750;
#P fasten 69 0 46 0 411 492 244 492;
#P fasten 65 0 46 0 237 492 244 492;
#P fasten 60 0 46 0 179 492 244 492;
#P fasten 48 0 46 0 360 492 244 492;
#P connect 47 0 46 0;
#P fasten 78 0 46 0 420 641 235 641 235 497 244 497;
#P fasten 66 0 71 0 172 546 244 546;
#P fasten 72 0 71 0 256 546 244 546;
#P connect 71 0 61 0;
#P connect 61 0 62 0;
#P fasten 73 0 72 0 307 544 340 544 340 524 256 524;
#P fasten 64 0 59 0 179 467 163 467 163 655 269 655;
#P fasten 52 0 51 0 395 682 269 682;
#P connect 59 0 51 0;
#P fasten 62 0 51 0 244 682 269 682;
#P connect 51 0 74 0;
#P fasten 76 0 75 2 300 750 282 750;
#P fasten 64 0 76 0 179 467 163 467 163 725 300 725;
#P fasten 75 0 73 0 242 882 532 882 532 521 307 521;
#P connect 39 0 34 0;
#P fasten 58 0 59 1 473 652 325 652;
#P fasten 51 0 53 0 269 710 338 710;
#P fasten 66 1 53 0 215 563 198 563 198 718 338 718;
#P connect 53 0 63 0;
#P fasten 39 0 41 0 323 24 351 24;
#P connect 36 0 35 0;
#P connect 35 0 37 0;
#P connect 37 0 34 1;
#P connect 50 0 48 0;
#P connect 46 1 55 0;
#P connect 55 0 56 0;
#P connect 51 1 54 0;
#P fasten 70 0 52 0 482 657 395 657;
#P connect 49 0 48 1;
#P connect 56 1 57 0;
#P connect 57 0 78 0;
#P fasten 19 0 17 0 568 45 439 45;
#P fasten 27 0 17 0 619 45 439 45;
#P connect 18 0 17 0;
#P fasten 77 0 17 0 615 191 430 191 430 49 439 49;
#P connect 17 0 24 0;
#P fasten 43 0 24 0 451 97 439 97;
#P connect 24 0 28 0;
#P fasten 34 0 28 0 323 168 439 168;
#P fasten 44 0 43 0 501 96 535 96 535 74 451 74;
#P fasten 24 0 40 0 439 122 463 122;
#P fasten 41 0 33 0 351 53 402 53 402 221 464 221;
#P fasten 28 0 22 0 439 246 464 246;
#P connect 33 0 22 0;
#P fasten 23 0 22 0 590 246 464 246;
#P fasten 22 0 25 0 464 274 464 274;
#P fasten 55 1 58 0 409 554 473 554;
#P fasten 55 2 70 0 456 584 482 584;
#P fasten 32 0 33 1 671 221 520 221;
#P connect 17 1 29 0;
#P connect 29 0 30 0;
#P connect 21 0 19 0;
#P connect 22 1 26 0;
#P fasten 41 1 23 0 371 49 406 49 406 217 590 217;
#P connect 20 0 19 1;
#P connect 30 1 31 0;
#P connect 31 0 77 0;
#P fasten 29 1 32 0 598 119 671 119;
#P connect 32 0 38 0;
#P pop;

#105397
May 30, 2007 at 1:49am

On May 29, 2007, at 5:03 PM, charles stankievech wrote:

> I too am having the non-realtime record patch producing incorrect
> timings.
>
> I’ve used non-realtime recording for a few years now and it works
> quite well in the past.
>
> But then all of a sudden, it doesn’t work any longer. I’m not
> exactly sure what has changed in my setup, but what i do know is
> that that patch hasn’t changed. I’m using the exact same patch and
> it records the video double or more. Even stranger it records it
> several times over.
>
> I am running MAX/MSP 4.6.1
> Jitter 1.6.1
> Quicktime 7.5.1

Please update your Jitter version (and Max too), and let us know if
your problem persists.

-Joshua

#105398
May 30, 2007 at 10:43pm

Mr. Kit,

Simply updating from Jitter 1.6.1 to 1.6.3 seems to have solved the problem.

Sorry, should have tried this first, didn’t know there was a newer version

Thanks greatly,

charles

#105399

You must be logged in to reply to this topic.