DSP Status and Audiotester for standalone

Oct 16, 2009 at 6:23am

DSP Status and Audiotester for standalone

There are quite a few posts suggesting adding “DSP Status” to my patch to get this to show up in my standalone runtime app.

Tried this dozens of times in simple to more complex examples, on Mac, PC, various OS versions – have never seen any affect – ie, doesn’t enable the menu option.

The problem is that I send small apps to other folks and they can’t get their I/O to work and we have no means to debug the problem.

=====
experimented with [menubar] but even copying the example straight out of the help file has no impact – the changes don’t show up.
=====

Probably something very simple.

Thank you for your help!

Peacesong

#45902
Oct 16, 2009 at 7:54am

this works for me:

– Pasted Max Patch, click to expand. –
#165420
Nov 1, 2009 at 10:12pm

This works great for DSP – thank you!

Is there a similar thing for loading “Audiotester”?

#165421
Nov 1, 2009 at 11:43pm

Tried adding Audiotester.maxpat to the menu – and it launches, but…

1) all aspects of the audiotester are non functional/grayed out
2) it only comes up the first time. once closed, it won’t open again until the app is restarted.

Here’s what i tried:

– Pasted Max Patch, click to expand. –
#165422
Nov 1, 2009 at 11:48pm

To open it when patching you can send a “load audiotester” message to the [pcontrol] object. The file is in the extras folder so you can always add it into your standalone from the build window/instantiate an [audiotester] object/drop the file into your application contents bundle after building it. If you need the full file path of your app try searching the forum or max help for “sendapppath”.

lh

#165423
Nov 2, 2009 at 12:00am

Hi lh,

Your suggestion works to launch audiotester…

however, when launched this way, audiotester does not function… dead/lifeless window.

Any thoughts?

Thank you,
Peacesong

– Pasted Max Patch, click to expand. –
#165424
Nov 2, 2009 at 12:09am

oops…

my error – built it wrong… it works! Smile

Than you!!!!!!

#165425
Aug 31, 2011 at 3:01am

After upgrading to the most recent version of MAX, audiotester no longer opens when delivered with as an application (runtime). no window at all comes up.

It works fine when opened with max full version.

#165426
Aug 31, 2011 at 5:05am

They’re Max patches, and can be included in your code in any way you like.

For instance

http://cycling74.com/2011/06/08/week-20/

-A

#165427

You must be logged in to reply to this topic.