ej.function curve messages

Feb 24, 2013 at 3:13pm

ej.function curve messages

Hello,
I’m using the very good ej.function external, but I can’t understand if I can set a point with a specific with a message like “set a point with x = 0, y= 0.5, curve = 0.7″ -> 0. 0.5 0.7. Or, better, change the curve of an existing point (0 0.0 0.5 0.7). It were very useful for automations!. The workaround is to use pattr (curves are exposed to the pattr system) and then interpolate between two slots, but it is not a very clean solution, and it messes with all the preset saving system.

Is there ar way to do that?
Thank you!
Sl

#66696
Feb 24, 2013 at 4:14pm

normal [function] can do curves too, if that’s all you’re looking for.

#240053
Feb 24, 2013 at 6:53pm

Thank you Wetterberg,
but as far as I know standard function objects do not have curve option (max 6).
I checked again and there’s no mention to it in the help-file.

PS: I made grammar mistakes in my post: with “if I can set a point with a specific with a message like” I meant: “if I can set a point with a specific curve via message”

Thank you again

#240054
Feb 25, 2013 at 9:44pm

In ej.function, there’s an addpoints message to add a point with x, y and c values. The standard function object has curve support as well since Max 6.0.7.

– Pasted Max Patch, click to expand. –
#240055
Feb 25, 2013 at 10:02pm

ah, didn’t know it was as recent as 6.0.7 it was introduced! eep!

I like to think it was Emmanuels ejies excellence that made it happen – it’s quite well implemented.

#240056
Feb 25, 2013 at 11:08pm

Thank you Emmanuel for the answer and above all for your great job!
Just out of curiosity (my problem is solved), the message [clear, xyc 0 0 1., xyc 500 1. 0.5] does not work (“function does not understand xyc”)
What should it do?

Thank you again!

#240057
Feb 25, 2013 at 11:24pm

Sorry, the second was the standard function. My mystake.

#240058
Feb 25, 2013 at 11:29pm

Why not update to the version of Max 6 which has the function object with curves?

#240059

You must be logged in to reply to this topic.