[ej.function.js]: Anyone else experiencing this?

Dec 23, 2009 at 12:12am

[ej.function.js]: Anyone else experiencing this?

Hi-

I’m using Emmanuel Jourdan’s lovely function jsui in an M4L device, and notice an issue with the mouse location. At first I thought the command keys weren’t working correctly, but it appears that the mouse location is offset up and to the left approx. 25 pixels.

Now that I understand what’s going on, when I click to add a point in a function, the added point makes the line jump down and to the right, while the mouse sits at the sweet spot. If I then shift-click, the point will disappear. Moving the mouse to the on-screen point location and clicking will add another point, or shift-clicking will do nothing.

Anyone else?

Charles

#47365
Dec 23, 2009 at 6:08am

Ummm…I’m not familiar with the object, but if you give me a patch, I’ll test it for you.

#170468
Dec 23, 2009 at 5:28pm

I’m unable to reproduce the issue. When I click anywhere in ej.function the point is created at that location.

#170469
Dec 23, 2009 at 9:56pm

Hi Emmanuel- I realized I’d inadvertently made the patching rectangle and presentation rectangle for your JSUI slightly different in size. I believe that’s what caused my problem; anyway it went away now that they are the same.

Thanks, Charles

#170470
Dec 23, 2009 at 10:17pm

Indeed that can cause the problem. jsui doesn’t support to have different patching/presentation at the moment.

#170471

You must be logged in to reply to this topic.