Forums > MaxMSP

Enttec DMX help

January 22, 2013 | 11:47 pm

Hi Everyone,

Just got an ENTTEC DMXUSB PRO and a small 4 channel DMX light……and can’t get it working!

i have tried the ‘dmxusbpro’ external and the enttec unit won’t show up, I have also tried ‘imp.dmx.usbpro’ and it DOESshow as connected in the mac window, but i cannot get it to control the light, or when i attach a print to the external i get no data coming through.

Im a little concerned that i haven’t got the drivers installed properly, when i open the ‘pro utility’ app that comes with the device it shows unable to connect! (see pic)

If anyone can help id really appreciate it, I am totally new to the DMX world!

Regards,

Oli

/Users/Oli/Desktop/Screen Shot 2013-01-22 at 23.36.16.png


January 23, 2013 | 10:17 am

Enttec don’t seem to link to it anymore, but imp.dmx.usbpro needs the FTDI VCP drivers in order to work. The D2XX drivers won’t work.

http://www.ftdichip.com/Drivers/VCP.htm


January 23, 2013 | 12:56 pm

Thanks for the reply.

That explains why your external connects and the other doesn’t!

I have tried sending DMX data to the imp external but no joy.

Is there any chance could put me a quick example patch together for a 4 channel DMX light? nothing fancy I just need it to works, so i can rule that out of my set up chain.

Would Appreciate it is you could.

Kind Regards,

Oli


January 23, 2013 | 2:08 pm

All you need to send to the object for four channel DMX control is a list of four integers between 0 and 255. One integer per channel Make sure you set your fixture to channel 1.


January 23, 2013 | 2:25 pm

Hi i have already tried sending a list of four integersand i got nothing, but i didnt set the channel, how are you setting to channel 1 im a little unsure?

Heres my attempt.

Regards,

Oli


January 23, 2013 | 2:38 pm

It depends on the brand of your fixture. Don’t you have any owner’s manual with it?

p


January 23, 2013 | 3:57 pm

Hi Patrick,

the manual can be find here http://prolight.co.uk/images//media/LEDJ01/LEDJ01-um0.pdf?ProlightConcepts=2990ad8b82fb58e8c3e5fa0962c51089
please excuse my DMX ignorance but Im not to sure what I am looking for.

I understand the channel 1 – 3 = RGB channels and channel 4 = Stutter/Dimmer Effect but i cannot get max to talk to the light!

Regards,

Oli


January 23, 2013 | 4:03 pm

Also not really to sure what I need to set the ‘dip’ switches to on the back!

Really appreciate it if someone could help me get going!

Regards,

Oli


January 23, 2013 | 4:29 pm

Your DIP switch:

set switch 10 to on (i.e. your fixture is controlled by DMX)
set switch 1 to on (i.e. the first channel of your fixture, the Red channel, is 1)
other switches to off.

On Max’ side send 255 to channel 4 to have the fixture’s global level set to its maximum, and RGB on channels 1-3

So if you send the list 255 0 0 255 to imp.dmx.usbpro, you should get pure red light.

p


January 23, 2013 | 4:33 pm

Great stuff, Im going to get on it soon as i finish work!

Thanks for taking the time, ill post back to let you know how I get on!

Regards,

Oli


January 23, 2013 | 6:24 pm

Thanks a lot Patrick working well now!

I was pretty close to getting it right, just didn’t get the dip switch, i incorrectly assumed that i needed dip switches 1 2 3 in for R, G and B channels.

Everything is great now!

@David Butler Great external BTW and thanks for your input.

Heres a patch might be useful for another beginner who is having similar problems to what i had.

Thanks again guys,

Regards,

Oli

– Pasted Max Patch, click to expand. –

April 21, 2013 | 1:30 am

I am having the same difficulties Oli is reporting. But unlike him, I still didn’t get any positive results. My interface is connected (appears in the max window), but I can’t get it to work properly. When I draw in the Multislider at the imp’s help patch, the Par LED I’m using (American Pro) goes crazy. Any clues? Thanks!


April 22, 2013 | 11:01 am

just a few thoughts,

is the slider controlling the correct dmx channel?

have you set the right amount of channels, even if you are not using the channel you still need a 0 in there. (e.g 5 channels light that only shows Red, 255 0 0 0 0.

Or you could try amending my basic patch (above) to suit.

All the best!


April 22, 2013 | 11:08 am

Thanks, Oli, I used your patch and also tryed the 255 0 0 0 0 option. Still no sucess!


April 22, 2013 | 11:23 am

you need to check how many channels your specific light has mine had 4 like in my example but yours could have more.

Check the manual first and if your still unsure send me the light model details and i will check for you.

Cheers


April 22, 2013 | 11:34 am

I found it! It’s 7 channels!



April 22, 2013 | 11:51 am

I put 255 0 0 0 0 0 0 to fill the 7 channels, still not working.

: (


April 22, 2013 | 11:57 am

Ok thats probably because one of the channels is the dimmer amount, which look like its set to 0.
What you have told the light is ‘you need to be red at max value 255′ but you have also told it ‘i want the dimmer to be at 0, which is off’

Try messing with input 4-7 on this patch and hopefully something will happen!

– Pasted Max Patch, click to expand. –

April 22, 2013 | 11:58 am

i prob should have explained that earlier, my bad.


April 22, 2013 | 12:07 pm

It’s all right, thank you very much Oli. I don’t have the manual, but I changed all the values and still nothing happens. When I click port a the messages are all right and the par can blinks once, so it seems like it’s connected. I can’t figure this out!


April 22, 2013 | 12:13 pm

I found a manual for a similar model, it says the dimmer channel it’s number 7.


April 22, 2013 | 12:14 pm

heres the manual;

http://www.americandj.com/pdffiles/64whledpro.pdf

check pages 8-10 (10 mostly)

you need to set the light to operate in DMX mode, this details how to do this.

also there is a table that tells you what each channel does, also what happens if you set that to a certain value.

have a play but this should do it.


April 22, 2013 | 12:17 pm
– Pasted Max Patch, click to expand. –

this should give you a red light.


April 22, 2013 | 12:29 pm

My LED par can is a little different, I don’t have the digital display. But I have a dip switch behind, so I turned on channel 1 and DMX, that should do it, right? But still no results.


April 22, 2013 | 12:36 pm

I would try the last channel maybe, mine is the last channel so might be the same.

you should really try and get the manual to get the most of (or at least something out the light :P )

If not set the light to a simple setting like red on and dimmer full then mess with the switches on the back to see what happened.

I don’t think there is much else you can do.

post back with how you get on, it might help someone later.

All the best,

Oli


April 22, 2013 | 11:42 pm

Hello Oli! Hi all!

I runned several tests here and I made some craaaazzzyyy progress, which seems to me totally random. It goes like this:

I have to send 7 values via pak to the imp.dmx.usbpro object (no channel message). Inlet 7 does all the trick as you predicted (the last channel). But I tested values from 1 to 512, and I only get results when I pass values 2, 17, 22, 24, 29, 32, 145, 152, 157 and 160. This numbers make the light blink fast different colors. The rest of values sent to inlet 7 gives me blackout. Inlets 1, 2, 3 and 6, until I reach value 63 don’t do anything, after that, blackout. Inlets 4 and 5 don’t have any effect at all.

Mistery!!! Maybe the DMX Gods can help me!

Cheers!


April 23, 2013 | 8:16 am

Glad you got it working!

i think if you get the manual you will be fine now.

what could be happening is one channel is conflicting with a another, in the sense that say channel 4 might be ‘slow fade’ and channel 5 might be ‘strobe’ and they conflict so they won’t run properly together…..maybe?!

All the best,

Oli


April 27, 2013 | 11:44 pm

At the end it was nothing so fancy at all, the cable I bought was built with the wrong soldering. I inverted the wires and everything is super now! Maybe the future guys can benefit from that: sometimes is the very basics that catch you! Cheers!


June 13, 2013 | 7:56 am

Hey guys,

I wonder if you can help me. I’m trying to use the imp.dmx with a Stairville – Par 56 – Black 151 RGB LED. What I’m trying to do is to set the light to white colour and have two separate sliders where can be used as a dimmer and the other will be used as a strobe.

As you can see on the patch, I have a multislider but it doesn’t to do the job I want to. Any ideas would be welcome.

Attachments:
  1. DMX-test.maxpat

June 13, 2013 | 8:21 am

Did you read this file, especially page 23?

p


June 13, 2013 | 8:31 am

Yeah i did. My problem is I’m not sure how to assign individual sliders to specific channels on the light.


June 13, 2013 | 8:55 am

I can’t test what I’ll write now, so please forgive any error!

If you set the DIP switch to 1 0 0 0 0 0 0 0, you’ll set the first DMX channel of your fixture to 1, which seems to be used to set the mode.
To get while light, you need to send the same value to R, G and B. So first send 63 to channel 1 (to set the DMX mode to RGB Control), then the same value to channels 2, 3 and 4.

So, I suppose that sending the list 63 255 255 255 to imp.dmx.usbpro should give white light.
And 63 128 128 128 softer white light.

Good luck!

p


June 19, 2013 | 1:00 pm

Great thanks !


February 21, 2014 | 5:59 pm

Hi Everyone,

I’ve installed the FTDI drivers (for the ENNTEC DMX USB PRO). My MacBook pro sees the box, Max sees the box (checking it with the serial object) but I CAN’T CONNECT TO IT (is really frustrating). I’ve tried in 2 different computers which makes me I’m missing something in the drivers part.

Any thoughts???

Thanks in advance,

Juan.


Viewing 35 posts - 1 through 35 (of 35 total)