EQ Distorts Sound

Feb 9, 2013 at 6:03am

EQ Distorts Sound

Hi All, Here is a 15 band EQ I made. It works almost exactly the way I want it to but for some reason, when I turn it on it distorts (makes louder) the sounds. Does anybody have an idea how I can make sure the songs sound the same when the EQ is on (and all frequencies are set to 0 db)?
Thanks

– Pasted Max Patch, click to expand. –
#66419
Feb 9, 2013 at 9:50am

Hi startec,
the distortion happens because resonant filters introduce distortion for their nature. You can try to reduce the volume boost reducing the filters’ gain and increasing the Q factor, so the various bands don’t overlap too much.

You may also have a look at the fffb~ (fast fixed filter bank) object, which does pretty much what you are doing, (there’s also an example patch with a 3d-of-octave-band EQ in the ‘examples’ patch) or use the filtergraph~ object to have a visual reference of how the eq’s affect your signal.

#239105
Feb 9, 2013 at 6:20pm

I recommend the crossover network that I posted in the other thread on this. It’ll sound way better and you don’t have to futz with resonance.

If you want a steeper rolloff when using a reson~ filter, however, I recommend using more than one reson~ in serial (each with the same settings). This sounds way better than just increasing the Q, as it gives you double the rolloff rate. With this trick, you can use a lower Q, but still achieve a steep rolloff. (this is known as a higher-order filter, since you’re stacking biquads; you can see how this looks using filtergraph with multiple copies of the same bandpass filter)

#239106

You must be logged in to reply to this topic.