Error: dac~ vector size mismatch

Oct 14, 2006 at 5:56pm

Error: dac~ vector size mismatch

Hi

For some strange reason, i get this error when turning audio on with the window:

Error: dac~ vector size mismatch

No files can play or anything.

Any suggestions – other than re-installing Max, which I suppose ought to work.

Even the sfplay~ helpful doesn’t work (and AudioTester)

Cheers,
Andrew

#28145
Oct 15, 2006 at 11:48am

Is it a new error – or has max never worked? sounds like a sound card driver error rather than a max error.
T

#86107
Oct 15, 2006 at 1:13pm

New error.

I’ve been running Max fine for several months.

I’ve put Max 4.6 on here now and that seems to work okay, so I guess upgrading might avoid this error.

Does anyone know what it was from though?

#86108
Oct 15, 2006 at 2:14pm

I still have problems on this one..

basically, i need FTM which I can’t get running on Max 4.6 so if anyone has any ideas on the mismatch error that would be great

#86109
Oct 15, 2006 at 7:00pm

This is probably way to obvious, but I’ll throw it in anyway in case you
haven’t tried already: Have you tried changing to another audio driver
in DSP Status, then selecting the one you are using again, reset signal
vector sizes and turn on audio again? I sometimes experience these
settings to be screwed up if I have been crashing Max.

Trond

Andrew Robertson wrote:
> I still have problems on this one..
>
> basically, i need FTM which I can’t get running on Max 4.6 so if anyone has any ideas on the mismatch error that would be great
>

#86110
Oct 16, 2006 at 12:12pm

Not way too obvious!

Has sorted the problem. basically, somehow the signal vector length had gotten set to zero and remained so, even when I re-installed.

Thanks very much for your help.

I set it back to 64. Anyone know a suggested value for this?

#86111
Oct 16, 2006 at 2:30pm

Glad I could help! I tend to use 256 or 512 for io vector size and 64
for signal processing. It is a good idea to keep them a power of two, as
many sound cards won’t support vector sizes that are not power of two.

Best,
Trond

Andrew Robertson wrote:
> Not way too obvious!
>
> Has sorted the problem. basically, somehow the signal vector length had gotten set to zero and remained so, even when I re-installed.
>
> Thanks very much for your help.
>
> I set it back to 64. Anyone know a suggested value for this?
>
>

#86112
Jun 1, 2008 at 12:13am

i had the same problem on max 5, but that sorted it out thanks!!!

#86113

You must be logged in to reply to this topic.