Forums > MaxMSP

error: send: <symbol>: already exists

December 22, 2007 | 10:28 pm

I’m lost here. I suddenly started getting these messages and my sends and receives don’t have inputs/outputs. Why did this kick in? Does it only kick in once the patch is a certain size? Is there an easy way around it?


December 23, 2007 | 12:48 am

Hmmm…seems to be a bug? It goes away when I reboot (but has since returned once). Possibly a OS 10.5 issue?


December 24, 2007 | 7:44 am

Adam Barnett schrieb:
> I’m lost here. I suddenly started getting these messages and my
> sends and receives don’t have inputs/outputs. Why did this kick in?
> Does it only kick in once the patch is a certain size? Is there an
> easy way around it?

All of them?, I guess not. I’d assume the error message is telling the
truth, you have somewhere a coll or buffer~ with the same name…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


December 26, 2007 | 8:04 pm

Further unto Stefan’s comment: If the term "namespace" means anything to you, be advised that Max doesn’t have any.

You can’t have any combination of [table foo], [coll foo], [receive foo], or [buffer~ foo] at the same time. Using a symbol for one purpose effectively blocks the symbol from being used for any other purpose for the entire duration of a Max session.

For big patches it is helpful to use naming conventions to avoid these sorts of conflicts. I make a habit of using names in the following form for bound symbols

xxxx.yy.theMainName

where xxx is a 2-4 letter abbreviation taken from the main top-level patch and yy is an abbreviation indicating the type of usage (bf for buffer~, tb for table, etc.). "theMainName" is whatever I want. This way I can open different patches without fear of name conflicts. If a patch is sufficiently complex I’ll insert another component into the symbol to indicate the subpatch.

You may also want to use the #0 convention.


December 28, 2007 | 9:32 pm

Peter Castine schrieb:
> Further unto Stefan’s comment: If the term "namespace" means anything
> to you, be advised that Max doesn’t have any.

Not quite true, the pattr system has a namespace and is almost complete,
the only object missing is a pattrbackward, but mostly some extra pattrs
can jump in…
It can be easily used instead of send/receive… (But seems more
expensive CPU wise…)

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


Viewing 5 posts - 1 through 5 (of 5 total)