Error to decode ;-)

Feb 22, 2012 at 9:05pm

Error to decode ;-)

HI all,
unfortunately I’m not yet capable of decoding errors in my system…
My Max application crashed, and i was wondering if anybody could give me some insight on how to understand where the problem is
thanks everybody

Attachments:
  1. error.rtf
#61923
Feb 23, 2012 at 6:50am

Hello,

NULL pointer access in [coll] object ?

#223609
Feb 23, 2012 at 2:18pm

Probably triggered by a ‘refer’ message to your coll.

#223610
Feb 24, 2012 at 11:37am

yep, it was a “refer thing”. so i assume this line

“Thread 0 Crashed: Dispatch queue: com.apple.main-thread
0 com.cycling74.coll 0x183f7b84 coll_refer + 41″

are the ones which report the origin of the crash.
I didn’t dig into creashreports before. Interesting.
does anybody know what “0x183f7b84″ and “+ 41″ stands for?
So next time I won’t bother you on the forum ;-)

thanks!

#223611
Feb 24, 2012 at 11:42am

I think you can safely forget those “0x183f7b84″ and “+ 41″
if you have a reproducible crash with your patch with the latest version of max please report it to cycling
It seems that you use 5.1.7 (runtime? standalone?) it might be worth to update to 5.1.9 or the latest version of max 6, maybe your problem is already fixed in those latest versions

#223612
Feb 24, 2012 at 11:46am

Hello,

I think it is the memory address of the function then the offset from there ; but i’m not really sure ;-)

#223613
Feb 24, 2012 at 3:10pm
#223614
Feb 27, 2012 at 1:34pm

mmm… this is driving me nuts. still not resolverd, and all the coll seems fine… i’ll try to install newest version of Max. Cross fingers… Thanks a lot vanille, Timo and Peter for your help!

#223615
Feb 27, 2012 at 2:16pm

… and the same problems occurs with Lion, too.
here’s the new crash report. looks like we have some more info here.. like this one:
__TEXT 0000000000001000-000000000037d000 [ 3568K] r-x/rwx SM=COW
in the link vanilla posted looks like it’s a problem related to read only memory, so this could point to some more interesting understanding… cross fingers…

Attachments:
  1. lion.rtf
#223616
Feb 27, 2012 at 3:07pm

Hello,

as Timo said you should FIRST isolate the problem in a max patch …

Anyway if
((your crash comes from a max object (as [coll])) && (you have the latest version))
then :

1. do it in other way (avoid refer) !
2. switch to max 6 as i’m pretty sure that (sadly) no update for max 5 is planned ;-)

Ciao.

3. switch to Pure data, learn Tcl, learn C and let’s go !

#223617
Mar 1, 2012 at 10:44am

ok, I solved the crash, and for maxers of the future I’ll share what the problem was:
i was referring a coll which wasn’t there!
a typo had max crashing, so.
Thanks a lot everyone who helped me.

I already have another crash, different from that one, but I’ll try to decode the creashlog myself, not to stress too much… ;-)

#223618

You must be logged in to reply to this topic.