Forums > MaxMSP

excluding a [pattr] object

February 12, 2006 | 11:02 pm

I use pattr to bind to a remote variable. In this little patch I want to
store the bindto target and its range mapping. What I DON’T want to store is
the value inside the [pattr] object, because it reflects a remote value.
Problem: I can’t exclude the [pattr] object from the parent system that is
used to store the other named objects in the patch.

Is there a way to exclude a pattr object? (autopattr 2nd outlet doesn’t work
like it does with regular named objects)

workaround 1: put the actual [pattr] somewhere else and work with s/r pairs.
This is not a solution I like, because I’m talking about a lot of parameters
here.

workaround 2: put pattr in a subpatch and block the parent pattrsystem by
putting a "dummy" pattrstorage inside the subpatcher containing the [pattr].
Not very pretty either….

I’d love to hear a clean way of doing this. Hope I make sense.

T_


February 13, 2006 | 8:12 am

I understand the problem you are having, but I’m not understanding
why you need to exclude the pattr. Typically, one uses pattr in order
to make a value available to pattrstorage — if you don’t want to use
the value in pattrstorage, you send the "active" message to psto to
disable the object in question. If that’s no help, you’re going to
need to be more specific about what you are trying to do, please.

It sometimes is helpful for us if you step back and try to explain
the larger goal you are trying to achieve, since we might be able to
suggest alternative solutions that aren’t obvious from a very narrow
context.

jb


February 13, 2006 | 10:50 am

Thanks again Jeremy, active is my friend:-) I’m using pattr to bind to
parameters that already have their own pattrstorage system. Modifications
are stored there, not at the controller side. That’s why.

Best, T_


Viewing 3 posts - 1 through 3 (of 3 total)