Forums > MaxMSP

Fantastick Hostname

May 1, 2011 | 11:15 am

Hi,
I’m trying to use the Fantastick App for Iphone and Ipad but when I want to launch the application, there’s the message "Please set hostname in Settings". I’ve already set my hostname (local.name) and I’ve try with my IP adress. Someone can help me?
Thanks.


May 2, 2011 | 9:28 am

hi,

On the latest iOS, you need to fully quit FS after setting the hostname to restart it. Double-click the home button, press and hold FS and quit it. Start again and the new hostname is used.

j


May 19, 2011 | 4:39 am

Hi,
How do you set the hostname ?
I have the same "Please set hostname in Settings" and the help file open on my laptop but I don’t get it.
Is ‘settings’ in FS on the iPad ?
Thanks.


May 26, 2011 | 12:24 pm

@Florent: "Settings" is the iPad Settings app (the metallic gears icon). When you open that, scroll down the list on the left, under Apps you’ll see all applications that have user settings in alphabetical order. Select Fantastick. The rest should be clear from there.

This is supposed to be the standard iOS user interface for changing application preferences, although not all apps use this approach.


May 26, 2011 | 12:33 pm

PS @jusu: Thanks for the instructions for quitting an app on iOS multi-tasking (to my embarrassment I hadn’t worked that one out yet). That helps with some of the problems I’d mentioned recently. I am still having trouble, which may possibly due to a flaky WiFi router. It basically seems that some drawing commands get dropped… I may need to press a message box two or three times before the next @ command does what I expect.

Also, the iPad I’m using at work is on iOS 4.2.1 and the machine that it syncs to has been taken out of the office for the next few days. I don’t know to what extent the OS upgrade to 4.3.x can make a difference to Fantastick’s reliability.


May 26, 2011 | 11:02 pm

Hi, the single most important factor is connecting to your laptop directly, thru a computer-to-computer (or adhoc) network, not using a router. If you’re using a router it will lose lot of packages. I’ll try improving this, but for now at least try it without a router to feel the difference..

j


July 21, 2011 | 3:38 am

Jusu,
I keep getting this message in Max: UdpSendernot ready to send. Beginner’s stuff, I know. Just not sure how to set up the local network properly. Can you please direct me?

Thanks!


August 22, 2011 | 6:06 am

Thanks a lot Peter.
After a few months I am back on this, and I managed to connect it.
That is awesome.
Thank you guys, and Mathieu Chamagne !

The general process is well documented here : http://pinktwins.com/fantastick/fantastick-guide.html

But about connexions :
1 Create Wifi Ad-Hoc Network on your computer, with no security.
2 Connect your iDevice to the same network.
3 In the patcher MMF-Fantastick.maxhelp you will find in "Connexion to iPhone…" and "what-is-my-IP address" your computer bonjour name. (I guess there is a faster way here, but it works).
4 Enter this name in the Fantastick settings in the iPad settings.
5 Restart Fantastick (a restart of Max may help).
6 Open MMF-Fantastick.maxhelp
7 Load an example patch in the umenu.

A simple way to check out if your connexion works is to open the Fantastick’s help.
You should see a white line moving.
Hope this helps.
Here is the patcher :

– Pasted Max Patch, click to expand. –

Viewing 8 posts - 1 through 8 (of 8 total)