Forums > MaxMSP

faster metro?

April 15, 2011 | 1:21 am

Hi,

I’m trying to count through 0 to 480 using a counter and a metro, but with the metro set at 1, it isn’t fast enough for my needs. How can I make it count faster? At the moment, the only solution I can think of is connecting up multiple metros to the counter, but there must be a more elegant solution.

I don’t want line because then I can’t change the speed in real time using a dial/slider.

Thanks.


April 15, 2011 | 1:56 am

Try using Uzi instead of Metro. I don’t know the specific speed but it goes from 0-n in very little time.


April 15, 2011 | 2:17 am

I originally thought about that, but I didn’t think there was a way to control the speed of the uzi. Is there?


April 15, 2011 | 2:22 am

I think that 1ms is about the resolution of the Max event world. I don’t think that you can go faster in the event domain. Perhaps if we knew what your were trying to do we could offer alternative approaches.


April 15, 2011 | 2:23 am

don’t know if it will work for your needs, but with my DSPStatus settings at a low vector size like 64, and with Overdrive and InAudioInterrupt on, this method of translating phasor~-type signal into bangs might work, i think there’s a limit to how fast events like bangs can be output no matter what, though…. anyways, in case it helps:

– Pasted Max Patch, click to expand. –

________________________________
*Never fear, Noob4Life was never here!*


April 15, 2011 | 2:59 am

@Chris

I am using jit.rota and trying to have the video scroll continuously vertically using offset_y. 480 is the the height of the image/video I am using. At the moment, it is counting through 0-480 too slow. Do you have a better suggestion?


April 15, 2011 | 5:53 am

I’m no jitter expert, but it seems to me that it doesn’t make any sense to have that metro running faster than the frame rate. Wouldn’t you just update by bigger increments? (e.g. don’t count to 480 one at a time, but use a phase increment)


April 15, 2011 | 5:54 am

Posting a patch of what doesn’t work is better than a description.


April 15, 2011 | 12:51 pm

Try increasing the step size.

-A


April 15, 2011 | 1:38 pm

Maybe connect number at the right inlet of metro, send value, maybe you can fix correct value of metro or qmetro after. so with the other post a patch and i send response..


Viewing 10 posts - 1 through 10 (of 10 total)