Feature request : folder @types …

Feb 19, 2009 at 3:05pm

Feature request : folder @types …

Hi,

Would it be possible to have types as an argument of the folder object, for example [folder @types WAVE AIFF]

Thanks

Leo

#42397
Feb 19, 2009 at 3:31pm

Please ignore.
Old style arguments do it perfectly.
I’m now so used with @ttributes…

[folder / WAVE AIFF]

Sorry for this.

Leo

#151748
Feb 19, 2009 at 3:43pm

#151749
Feb 19, 2009 at 6:16pm

On Feb 19, 2009, at 7:43 AM, f.e wrote:

> That’s cool to know, because while i was building a workaround for
> your problem, i discover that you can’t set more than one kind of
> types using the “types” message. It’s either WAVE, or AIFF, not
> both…

Not true, it can be a list of types:

– Pasted Max Patch, click to expand. –

Chris Muir
cbm@well.com

http://www.xfade.com

#151750
Feb 19, 2009 at 6:21pm

#151751
Feb 19, 2009 at 10:59pm

Quote: Chris Muir wrote on Thu, 19 February 2009 19:16
—————————————————-

> Not true, it can be a list of types:

> Chris Muir
> cbm@well.com
> http://www.xfade.com
>
>
—————————————————-

I just tried your patch but the umenu shows also a non AIFF WAV type (see attached pict). Is this a bug or did I miss something?

ole

#151752
Feb 19, 2009 at 11:36pm

Did you trigger the [loadbang]? It won’t fire automatically when you copy the text from the forum, only when you save and re-open the patch.

lh

#151753
Feb 20, 2009 at 8:40am

Quote: thereishopeforus@hotmail.com wrote on Fri, 20 February 2009 00:36
—————————————————-
> Did you trigger the [loadbang]? It won’t fire automatically when you copy the text from the forum, only when you save and re-open the patch.
>
> lh
—————————————————-

yes I did

ole

#151754
Feb 20, 2009 at 8:57am

On Feb 19, 2009, at 2:59 PM, Ole Schmidt wrote:

> I just tried your patch but the umenu shows also a non AIFF WAV type
> (see attached pict). Is this a bug or did I miss something?

It seems like folder also passes invisible files done the good ol’
Unix way (leading dot in the filename.)

I don’t think that this has anything to do with passing in multiple
types in one types message.

- C

Chris Muir
cbm@well.com

http://www.xfade.com

#151755
Feb 20, 2009 at 1:44pm

#151756
Feb 20, 2009 at 8:14pm

I can’t seem to reproduce here. Here, no dot files are shown when I set a file type.

Out of curiosity, do you have the showdotfiles attribute set to 0?

-b

#151757
Feb 20, 2009 at 8:34pm

Quote: ben@cycling74.com wrote on Fri, 20 February 2009 21:14
—————————————————-
> I can’t seem to reproduce here. Here, no dot files are shown when I set a file type.
>
> Out of curiosity, do you have the showdotfiles attribute set to 0?
>
> -b
>
—————————————————-

No, how can I do that?

ole

#151758
Feb 20, 2009 at 8:48pm

you can do this in umenu’s inspector, or send a ‘showdotfiles 0′ message to umenu. However, I believe that showdotfiles are set to 0 by default, so if you didn’t set it in the first place, then something else is wrong.

Do all dot files get listed? Is there a particular file that gets listed?

I assume you are using Max 5.0.5? What platform/OS?

-Ben

#151759
Feb 20, 2009 at 8:58pm

On Feb 20, 2009, at 12:14 PM, Ben Bracken wrote:

> Out of curiosity, do you have the showdotfiles attribute set to 0?

Of folder? Is such a thing documented?

At any rate, unless it’s the default, I don’t.

What might be worth mentioning, is that to reproduce this based on the
screenshot Ole posted, I took one of the wave files in my test
directory, and from the terminal did:
cat myWave.wav > .myWave.wav

so in my test folder included .myWave.wav, which was a valid wave
file. Ole’s test looks like it found a non-wave .file, though.

- C

Chris Muir
cbm@well.com

http://www.xfade.com

#151760
Feb 20, 2009 at 9:06pm

No, of umenu. Sorry, did not read close enough that this was about [folder], not umenu.

-Ben

#151761
Feb 20, 2009 at 9:09pm

Quote: ben@cycling74.com wrote on Fri, 20 February 2009 21:48
—————————————————-
> you can do this in umenu’s inspector, or send a ‘showdotfiles 0′ message to umenu. However, I believe that showdotfiles are set to 0 by default, so if you didn’t set it in the first place, then something else is wrong.
>
> Do all dot files get listed? Is there a particular file that gets listed?
>
> I assume you are using Max 5.0.5? What platform/OS?
>
> -Ben
>
>
>
—————————————————-

I have sent a message with “AIFF, WAV” to the folder object and the only file beside aiffs and wavs is that invisible timemachine file that is listed. showdotfiles in the inspector is unchecked.
Im am on Mac OS 10.5.6 using Max 5.0.5

ole

#151762
Feb 20, 2009 at 9:14pm

there is some confusion now with folder and umenu, but anyway, as far as I understand, the file starting with a dot should not be shown in the umenu or did I missunderstood something?

ole

#151763
Feb 20, 2009 at 9:22pm

[umenu] also seems to have stopped following aliases, as the [ubumenu] used to do.

Max 5.0.5
Mac OS 10.5.6
MacBookPro

–NW

#151764
Feb 20, 2009 at 9:24pm

Quote: ole_schmidt wrote on Fri, 20 February 2009 22:14
—————————————————-
> there is some confusion now with folder and umenu, but anyway, as far as I understand, the file starting with a dot should not be shown in the umenu or did I missunderstood something?
>
> ole
—————————————————-

sorry for the noise, when I choose “AIFF” and “WAV” filetypes in the umenu, there is no dot file shown…
I’am afraid I don’t understand the whole sense of the folder object.

ole

#151765
Feb 23, 2009 at 1:29pm

fe: folder AIFF WAVE works here.

#151766
Feb 23, 2009 at 1:33pm

>I have sent a message with “AIFF, WAV” to the folder object and >the only file beside aiffs and wavs is that invisible >timemachine file that is listed.

no comma

“types AIFF WAVE” …

i think its nowhere documented but it should work like the dropfile object and support up to 64 types all written into one list

-110

#151767

You must be logged in to reply to this topic.