[fiddle~] "unknown external object type"

Feb 24, 2011 at 8:55pm

[fiddle~] "unknown external object type"

Trying to use [fiddle~] again for some tutorials I’m going through and I’m experiencing the message “unknown external object type” when I attempt to instantiate the object. any ideas what this? Thanks.

fiddle~ 1.2 | Max 5.1.7 | OS 10.6.6

#55163
Feb 25, 2011 at 12:29am

Hello,

I think you have to put the external in the same folder as your patch, then click on options then preferences file from the path to the folder containing the patch and abstraction, closes and opens the max, open the patch, and it should work.

#198542
Feb 25, 2011 at 3:44am

From memory, fiddle~ 1.2x does not work on Intel (and/or Max5). Find Tristan Jehan’s analyzer~ which is virtually a drop in replacement for fiddle~.

#198543
Feb 25, 2011 at 9:21am

pitch~ from cnmat is the real drop in replacement for fiddle~. for a better solution use sigmund~, but you will have to repatch and rethink a bit. i have forced fiddle~ to work on intel in the past actually, but cannot remember how i did it sorry. i seem to remember it was dsp settings and ignoring the errors! good luck.

#198544
Feb 25, 2011 at 8:07pm

Just in case anyone’s interested, I submitted a windows port of fiddle~ 1.2 and bonk~ 1.3 by Ted Apel. I used MaxSDK 5.1.6
It works fine under windows. Make sure you open the help to see how to properly use fiddle~.

warm regards

#198545
Feb 25, 2011 at 8:42pm

Ok what mortimer said worked. For some reason having a copy of the external in the same directory as the patch you’re using it in will let it work.

And I have pitch~ and sigmund~ installed, I was just trying to follow this tutorial precisely. Its Barry Moon’s “patch a day” tutorials I’m doing and I did wonder about this because in an earlier tutorial he used sigmund~ and then I get to this later one and he uses fiddle~, but I assumed there was something different about the two objects. I need to compare all three and actually learn their functions better.

#198546

You must be logged in to reply to this topic.