Forums > MaxMSP

File association on Windows

November 26, 2008 | 3:55 pm

Hi all,

I work on Windows (i noticed the same problem on XP and Vista).

My problem : i don’t manage to associate .maxpat extension with Max 5! maxpat files can only be associated with Max 4, Notepad or Wordpad.

From a Windows browser, if i right click on the file, then choose "Open with" there are only Max 4, Notepad and Wordpad in the list. If i try to right click on the file, then choose "Open with > Choose the program…", "C:Program FilesCycling ’74Max 5.0Max.exe", the .maxpat file still opens either with Max 4, Notepad or Wordpad.

Am i missing something?

Thanks


November 26, 2008 | 4:34 pm

Just a correction : i only have this problem on Vista ; it works on XP. Thanks.


November 26, 2008 | 5:32 pm

In Windows Vista…

Go to Control Panel (make sure you are in classic view)
Go to Default Programs
Click on "Associate a file type or protocol with a specific program"
Find .maxpat, and click Change Program
Navigate to Max 5

Does that help?


November 26, 2008 | 5:54 pm

Max 5 creates its file associations on launch (as opposed to with the installer). Make sure you have actually launched max 5 once on your vista machine. I expect that you have, so another possibility is that there could be a permissions issue preventing max from creating the registry keys necessary to associate its file types.

If you can run Max once as an administrator on that Vista machine then you might be all set…

Rob


November 27, 2008 | 10:00 am

Thanks a lot Rob, it works! I just had to launch Max as administrator once and now i can choose Max as the default app for maxpat files.


Viewing 5 posts - 1 through 5 (of 5 total)