Forums > MaxMSP

Filter, How to make Cutoff Frequency Control Without clicky sound.

May 10, 2012 | 9:10 pm

Hi. All

I need to use one midi channel to control a lores~ ‘s cutoff frequency. So the range of MIDI signal is as usual 128 steps. And the cutoff frequency range I aim to set from 0Hz to 2kHz.

So that each step change will lead to quite a jump of the frequency change. I try [line] to linearize the control input and also another [lores~] with cutoff frequency of 2000 just try to smooth the cut-off frequency input. But still when I turn the knob it sounds quite clicky.

Is there any solution for this? Please help,\

Many Thanks

Jiajun


May 11, 2012 | 7:02 am

Hi,
Do you use [line] or [line~]to smooth the frequency value?



dtr
May 11, 2012 | 7:17 am

scale your midi value to your Hz range, use sig~ to turn it into an audio signal, use line~ or slide~ with a large enough settings to smooth out the steps. it’s important that you do the smoothing in the Hz range, not in the midi range. if this doesn’t work you didn’t set the smoothing settings right.


May 11, 2012 | 7:38 am

– Pasted Max Patch, click to expand. –

Viewing 4 posts - 1 through 4 (of 4 total)