Forums > MaxMSP

filtergraph display mode

August 22, 2006 | 6:48 pm

hi

I’m using a filtergraph~ in cascade mode (5 filters) to create
various different filter presets. I’m storing the presets as lists of
filter coefficients from outlet 1.

I also want to be able to load the presets back into the filtergraph
to further edit them, but every time I send parameters to the
filtergraph it switches into display mode. I’ve looked to see if
there’s a message (or message per filterbank) to reset the banks to
peaknotch, but can’t seem to find one that’ll do it. I can send
[peaknotch] to the filtergraph, but that only sets the first filter
to the right mode.

Have I missed something obvious? Or obscure?

While I’m here – I was also trying to make a 5 bank filter that
morphed between random settings, but I don’t know enough about
filters to know what ranges of parameters would make sense. (Ie I
wanted to use random number generators to send filter coefficients
to filtergraph). It may well be that this won’t actually work – but
just in cases – are there ranges of values that I could randomise
that would produce meaningful results in biquad?

thanks

David


January 3, 2013 | 1:37 pm

Bonjourno old thread.

I have a similar enough problem to bump this, I think.

I’d like to ‘link’ filtergraphs, but for some reason the one being sent coefficients goes straight to display mode, meaning I can’t change it’s frequency.

I have tried to illustrate this below.

– Pasted Max Patch, click to expand. –

January 3, 2013 | 3:04 pm

hola,

– Pasted Max Patch, click to expand. –

January 3, 2013 | 3:24 pm

Thanks marcooder!


January 3, 2013 | 9:05 pm

How about more than one? : /

– Pasted Max Patch, click to expand. –

Viewing 5 posts - 1 through 5 (of 5 total)