"floor noise", complete silence makes click once I hit the keyboard

Sep 2, 2013 at 6:19pm

"floor noise", complete silence makes click once I hit the keyboard

HI!
I’m making my own synth, and for now i’ve got OSC, Modulation, + Filters, and at the end my AMP envelope.

The problem is, that If it is at complete silence, and waveforms OFF, when I play any key from my midicontroller, I hear like a CLICK after the AMP envelope,
I put the Spectroscope~ and it’s clearly something below 30-40Hz for sure.

I’ve tryed to put a biquad~ 1. -1. 0. -0.9997 0. before de ezdac, cause I have no idea how to calculate this coefficients, I did search it from the forum….

My envelope adsr, is activated by the velocity I get from the ddg.mono output.

Once, something is multiplied by the velocity , I think it rases the DC level?? It is a matter of a good HPF filter at the end??

thanks for your help, and time. appreciate it.

#264065
Sep 2, 2013 at 7:13pm

Yes, it might be DC coming into your amp. hightpassing before the [*~] might solve this,
but if you think your “DC” has a freq of 30 to 40 Hz, than this is not a good solution.

You can, by the way compute coefficients with the filtergraph object for example.

If you post the patch, maybe we find the source of the noise.

I actually don’t quite understand why you don’t go backwards through the signal way and see where the noise is coming from. I mean it should be present all the time at the input of your [*˜]

One comon thing that causes clicks are too short envelopes, but this shouldn’t be the case here since you say there shouldn’t be any signal present to be multiplied with an envelope.

Cheers

#264067
Sep 2, 2013 at 9:17pm

It is the last envelope, tha AMP envelope(adsr~), cause i’ve been trying it doing reverse signal… Once I set a high attack…200ms…(6ms is my initial enable)..something like that….clicks are not heared, when I keep pressing a key from the keyboard, but there is no signal sending to the EZDAC~

How do I post my patch..? It’s quite big…with 4 bpatchers…that don’t get copied with the copy compressed.

#264074
Sep 3, 2013 at 10:12am

Click on your bpatchers go to inspector, check “embed”(maybe don’t save this..) and copy compress/paste here.

#264116
Sep 3, 2013 at 12:25pm

Thanks = )
I didnt know that =) what a newbie I am hehe

appreciate it!

I’ve had to attach it in a text file, cause dunno why, all times i’ve tryed to paste it here, it says server error….

Thanks again for your time.

#264131

You must be logged in to reply to this topic.