Forums > MaxMSP

Folder Object not working

June 11, 2012 | 7:16 pm

I am trying to use a "folder" object to report the number of aiff files in a specific folder, but it is not populating the attached umenu OR reporting the number of items from the count outlet. The interesting thing is that it works for the parent folder:
"Macintosh HD:/Users/Jason/Documents/Computer Music projects and components/Sounding Circle" works but not ""Macintosh HD:/Users/Jason/Documents/Computer Music projects and components/Sounding Circle/SCGhosts".
What gives?


June 24, 2012 | 4:22 pm

Hi Jason,

I was having a very similar issue last night, and I’ve managed to figure it out a little bit this morning. I’m a fairly new Max user (only been working with it since about November 2011), full disclosure. YMMV, but here’s what I did:

I ended up going into the help patcher for the folder object, and basically copying the entire thing and dropping it into my patch. Then I dragged a folder to the dropfile object, and connected the left outlet to a message object so I could see what was coming out of it, and a number box to the right outlet to get the count.

There seems to be an order of operations thing going on, maybe it’s just voodoo, but when I sent a clear message to the umenu, then changed the umenu for file type to something I was looking for, and then dropped a folder onto the dropfile object, I got the expected results.

From there, I just whittled it down and changed it to be basically what I was looking to do.

HTH!

Cheers,

-Maashu


Viewing 2 posts - 1 through 2 (of 2 total)